Failed to receive the answer (from Suunto Vyper Air)

Amit Chaudhuri amit.k.chaudhuri at
Wed Jun 20 05:45:56 PDT 2012

Thank you for the feedback.  I think I need to play around with

> Make sure you dry your computer - if you were just diving with it you
> might rinse it off in fresh water and then use the cylinder to blow
> lots of air over the contacts of the Vyper Air. That tends to help a
> bit. And then just try again. Re-seating the connector to the Vyper
> Air seems also to help sometimes. It can take a few tries, but at
> least current subsurface makes it easier to retry (it used to be that
> you had to go back to the import menu and select your dive computer
> all over again, now you can just hit "retry").
Computer spent the night in a cupboard with the boiler in it so was dry as
you like, so it's not that one.

> If it really never goes away, try opening your cable up. For me, it
> literally was a loose cable inside the connector. But I doubt that
> would ever have worked with SDM either, so if it works for you with
> SDM, it's probably just flakiness.
I'm thinking flakiness at this stage.  Wondering if it might be to do with
timing / system capabilities.

> Linus
> If the failure is during the first data packet, then this is a known
> problem
> with the vyper2 class devices. For some unknown reason the communication
> fails
> to startup properly the first time you try, but if you retry immediately
> again
> it usually works. Unfortunately we don't know what the underlying problem
> is. It
> might indeed be some timing issue. If anyone has some suggestions, let me
> know!
> Jef
Tried the immediate retry idea (thanks) and it consistently fails.

I will add some diagnostics to libdivecomputer and recompile & re-test.
I'll update in a few days with any results.

If you have any suggestions for other things I might try I'm open to having
a tinker.  I've no experience of reverse engineering protocols but I am not
afraid of a bit of research and some C/C++.



P.S. I just did a very nice exercise this weekend involving 2 minute hovers
at 15, 12, 6, 5, 4m and then 1 min @ 3, 2, 1. Looks pretty good on my
SuuntoDM4 export - so I'm feeling quite pleased with myself. If I could
just get it  onto subsurface too I'd be unbearable.  ;)

[It's part of the British Sub Aqua Club's bouyancy & trim course.]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list