Fwd: feedback on experience with OSX packaging

Dirk Hohndel dirk at hohndel.org
Thu Oct 4 21:42:27 PDT 2012

Jef / folks on the subsurface mailing list - Amit had an email bounce
several months ago and this slipped through the cracks. I finally found
it and am now trying to get things to work for him.

Since then he tried the latest 2.0-rc1 package and the problem seems to
boil down to this:

Amit Chaudhuri <amit.k.chaudhuri at gmail.com> writes:

> I try an connect my Suunto Vyper Air using USB cable.
>   Device is powered down.
>   Insert cable in to Mac Book
>   Insert into Vyper Air
>   Device reports switched into Data Transfer mode (i.e. on screen of
>   dive computer). 
>   Menu option Log | Download from DC does nothing for circa 20 sec
>   When it brings up Download from Dive Computer dialog it has remembered my
>   last choice (Suunto Vyper Air) and device name - /dev/tty.SLAB_USBtoUART
>   error message below is Unable to open Suunto Vyper AIr
>   (/dev/tty.SLAB_USBtoUART)
> I have Suunto Dive Manager installed on the same machine and it will talk
> to my Vyoer Air dive computer. However, subsurface will not yet recognise
> the device. Error message from subsurface is:
> Unable to open Suunto Vyper Air (/dev/tty.SLAB_USBtoUART)

So this means that you most likely HAVE the correct kext installed
(otherwise the Dive Manager wouldn't be able to talk to the Vyper Air).

My guess would be that the device name is wrong, but I'm on a plane and
can't even Google for this. Jef - any suggestions (as this is clearly
libdivecomputer territory)?

> With subsurface running and the usb cable plugged into the dive computer
> the unit switches into a mode which writes "data transfer" into the display
> but that's about it.
> Any advice on troubleshooting much appreciated.
> I have not added any specific drivers (perhaps naively) I assumed that this
> might not be necessary given the SDM4 installation is operational.  I was
> also unsure about the section of the documentation which mentions manually
> hunting for drivers.  How would one know that Mac_OSX_VCP_Driver is right
> for the Mares Puck? Is it also right for Vyper Air?

Great question. Again, maybe Jef has a pointer to his documentation that
would clear that up?

> I would also like to get this working with my Gekko, so any secondary
> pointers there would also be welcome.  For info, I called Suunto customer
> services to ask them about accessing the dives on my  Gekko (now that I
> have a shiny new Vyper Air I thought they might be a little helpful; sadly
> wrong). So I suspect that if you can craft packaging and docs to explain
> how to get data from Gekko's onto subsurface you might tap into an
> interesting niche.  Many divers starting out in the UK in the last few
> years will have been brought up on Gekko and would be delighted to work
> around the unhelpfulness of Suunto in this matter.

I know this worked with the Gecko for me (when I still had it).

And while it can be hacked to work with the Suunto Dive Manager software
I don't think that hack is required to work with Subsurface...

Let's figure out the correct dive to use and take it from there.


More information about the subsurface mailing list