Subsurface 2.0 has been tagged

Henrik Brautaset Aronsen subsurface at
Sun Oct 7 07:39:17 PDT 2012

Den 07.10.12 16:08, skrev Henrik Brautaset Aronsen:
> Den 07.10.12 15:44, skrev Dirk Hohndel:
>> Hmm. Strange. All I can say is "it worked for me". I don't have access
>> to the build machine until next weekend; it would suck not to have Mac
>> binaries until then, but maybe that's what it is...
> Having the /opt/local prefix fixed the libdivecomputer link, but I'm 
> unable to solve the other problems. Dang.

Solved most of the problems.  Only the font problem left now.  (see 
attached patch).

-------------- next part --------------
>From a43da091d9d404907e37694e118f1e3c829df987 Mon Sep 17 00:00:00 2001
From: Henrik Brautaset Aronsen <subsurface at>
Date: Sun, 7 Oct 2012 16:33:06 +0200
Subject: [PATCH] More gtk-mac-bundler improvements

Without "-headerpad_max_install_names", gtk-mac-bundler would complain
with "changing install names or rpaths can't be redone for:
/Applications/ (for
architecture x86_64) because larger updated load commands do not fit"

Also, libdivecomputer needs to be configured with

Signed-off-by: Henrik Brautaset Aronsen <subsurface at>
 Makefile                |  1 +
 packaging/macosx/README | 19 ++++++++++++-------
 2 files changed, 13 insertions(+), 7 deletions(-)

diff --git a/Makefile b/Makefile
index a954f54..5db1dfc 100644
--- a/Makefile
+++ b/Makefile
@@ -104,6 +104,7 @@ else ifeq ($(UNAME), darwin)
 	MACOSXFILES = packaging/macosx
 	EXTRALIBS = $(shell $(PKGCONFIG) --libs gtk-mac-integration) -framework CoreFoundation
 	CFLAGS += $(shell $(PKGCONFIG) --cflags gtk-mac-integration)
+	LDFLAGS += -headerpad_max_install_names
 	OSSUPPORT = windows
diff --git a/packaging/macosx/README b/packaging/macosx/README
index 88a383d..a1a7cda 100644
--- a/packaging/macosx/README
+++ b/packaging/macosx/README
@@ -1,22 +1,27 @@
 Creating a Subsurface bundle
 install gtk-mac-bundler (this has been tested with version 0.7.0) and run
-gtk-mac-bundler subsurface.bundle
+  $ gtk-mac-bundler subsurface.bundle
 This should install a self-contained Subsurface application under /Applications/
 You still need to manually build a DMG if you want to easily distribute this.
-One important caveat is that (at least with MacPorts) you need to build pango like this:
-sudo port install pango +builtin_modules +no_x11 +quartz
+* You need (at least with MacPorts) to build pango like this:
+  $ sudo port install pango +builtin_modules +no_x11 +quartz
 Without the builtin modules the installed application fails to find the modules and doesn't render any text.
-Also, it seems that gtk-mac-bundler expects the charset.alias file to be
-in the ${prefix}/lib folder which it isn't with the current version of
-MacPorts. The following fixes that:
+* It seems that gtk-mac-bundler expects the charset.alias file to be
+  in the ${prefix}/lib folder which it isn't with the current version of
+  MacPorts. The following fixes that:
-sudo cp /usr/lib/charset.alias /opt/local/lib
+  $ sudo cp /usr/lib/charset.alias /opt/local/lib
+* libdivecomputer needs to be configured with --with-prefix=/opt/local

More information about the subsurface mailing list