windows issues with gettext

Lubomir I. Ivanov neolit123 at
Mon Oct 15 13:33:50 PDT 2012

On 15 October 2012 23:25, Dirk Hohndel <dirk at> wrote:
> "Lubomir I. Ivanov" <neolit123 at> writes:
>>>> what should be done here to make the menus work?
>>> Is that all menue entries or just some? Is that with the latest master?
>>> And current .mo files? The limited testing that I did on Win7 32bit
>>> seemed to work - but I'm not 100% sure if I checked the menues or just
>>> the program itself...
>> it looks like all menu entries are affected, but not the dialogs such
>> as "about", "open" and others.
> Just to understand, this is with the environment variable
> LANGUAGE="bg_BG.UTF-8" set prior to starting subsurface?

the menu problem affects all bundled languages not only bg_BG.
yes from my tests, on windows 7 nothing else works except LANGUAGE=...
in terms of setting env. variables.

>>>> ------
>>>> 3) i'm seeing a gettext bug on windows that seems to affect all
>>>> translations. title of the "add dive" dialog has invalid UTF-8
>>>> characters.
>>> Is this a font problem? I.e., which character is supposed to be there in
>>> your locale and does that glyph exist in the font that you are using?
>> seems that the strings are truncated for all languages in the dialog:
>> fr -> Plo
>> de -> Tau
>> bg -> It shows some odd characters + the pango message (which is also
>> due to truncation)
>> font is the default "Sans" on win32.
> Ahh, this is not a font problem - the code used there appears buggy.
> It modifies memory that it shouldn't modify. I'll push out a fix in a
> moment.
>>>> i'm having some troubles switching my locale on the linux distros i
>>>> have. so i can't confirm the same there.
>>>> "Locale not supported by C library."
>>> Which locale are you trying? I assume this is Ubuntu?
>> i've tried most locales with LANG and LANGUAGE (LC_ALL is locked).
>> i think that i actually have to compile the .mo files for linux first!
> Yes, you need .mo files. But running make on Linux should do that for
> you (in the ./locale folder).
> For me LANG="de_DE.UTF-8" works fine...

i've compiled the .mo files on both debian and ubuntu, but still get
no translations.
ubuntu still reports "Locale not supported by C library." regardless
of settings.
in terms of settings, i've tried LANG=, LANGUAGE=, and LC_ALL= for
both distros with no results for various of the bundled translations.
perhaps another debian-like OS user can confirm - not sure whats going on.

my default locale on both distros is en_US.UTF-8


More information about the subsurface mailing list