Dirk Hohndel dirk at hohndel.org
Mon Dec 2 07:04:13 UTC 2013

On Mon, 2013-12-02 at 14:10 +0200, Willem Ferguson wrote:
> Dear subsurface community,
> Please write to this mail list, listing
> 1) which dive computer(s) you have used

Heinrich and Weikamp OSTC2 - no problems - /dev/ttyUSB0

Heinrich and Weikamp OSTC3 - no problems - /dev/ttyUSB0

Uemis Zurich SDA - no problems - /run/media/<username>/UEMISSDA

Mares Puck Air - no problems - /dev/ttyUSB0

Shearwater Petrel - with the known Bluetooth issues - never tried their
dongle - devicename from rfcomm

Suunto Mosquito - no problems - /dev/ttyUSB0

Suunto Gekko - no problems - /dev/ttyUSB0

Atomics Aquatics Cobalt  - no problems - /dev/ttyACM0

> 2) Whether it/they worked out-of-the-box in uploading dives to 
> subsurface, or whether any special setup was required to get the DC to 
> upload dives to subsurface.

Unsurprisingly they all work for me.

> For example, here is my rather short list of experience:
> Mares Puck 2: out-of the box, using device ttyUSB0 on Ubuntu
> Mares Puck Pro: out-of the box, using device ttyUSB0 on Ubuntu
> What happens with Uwatec DC's or Suunto D9 tx?
> The above information is required to get the upload information in the 
> user manual as current as possible. We regard this as CRITICAL for the 
> use of subsurface, especially if any special setup was required to 
> achieve dive upload from a particular DC.

Yes, please people, help Willem


More information about the subsurface mailing list