Some recent change completely broke the DC import

Lutz Vieweg lvml at
Thu Dec 26 11:19:23 UTC 2013

On 12/26/2013 07:32 PM, Dirk Hohndel wrote:
> What's the significance of the ~/subsurface directory?

The only thing I know for sure is that it contains the "diver.xml"
file which is used for saving dives by subsurface (for the user named

> Are you running different binaries in these two scenarios?

No, the tests I did after your last email and before my last reply
were all done using
> [diver at computer ~]$ ~/bin/subsurface --version
> Subsurface v4.0-64-gd42cc5a40c41, built with libdivecomputer v0.5.0-devel (c5249861758305cff525a02e0a243f65b0750862)

> Your configuration on a Linux system is stored in
> ~/.config/Subsurface/Subsurface.conf

Will try to move that file away next time I can test to make sure
it's not keeping a state that makes a difference for reproduction.

> Is your default data file in ~/subsurface ?


> Is it possible that there are new dives on the dive computer, i.e. that
> all your dives are already downloaded if you have your ~/subsurface
> directory in its usual place?

I never used my "usual" user account for all those video-related
subsurface runs, that user named "diver" should have started without
any dives (especially after moving away ~/subsurface).

Is there a place besides the .xml file where a state regarding
"when was the last dive?" is being stored? Does libdc store some
state of its own?

I also tried imports with "force download of all dives" checked,
and that did not help when the import yielded no entries.

>> Another exit, another restart then import, and the import
>> worked again.
> Wait - so even if you remove the ~/subsurface directory, on the second
> attempt it works?

Yes, and that confuses me, too.
I wonder whether I am fooled by effects of a small statistic sample -
but whenever an import failed, it failed every time until I exited
subsurface. And whenever it worked, it kept working (at least)
until I exited subsurface. And in no case there was any kind of
error message.

>> So my only way for reproduction currently is to start without
>> an existing ~/subsurface directory.
> I'm mildly confused about the exact steps when it does or does not work.
> Sorry to make you repeat yourself, but understanding what triggers this
> might help track it down...

I'm just as confused, maybe we have to postpone the analysis until I
do not need to record further video, because mixing runs to reproduce
this issue and runs to record some video might add to the confusion.

If there is additional debug output I could enable (besides the two
libdc dump options already used) please let me know.


Lutz Vieweg

More information about the subsurface mailing list