[BUG] Cancelling dive planning from keyboard

Dirk Hohndel dirk at hohndel.org
Thu Feb 21 05:54:42 PST 2013

Miika Turkia <miika.turkia at gmail.com> writes:

> Hello,
> I played around with the dive planner a bit on taxi and discovered a
> bug. When I cancel the dive planning from keyboard, the dive is not
> deleted (as when clicking the cancel button with mouse).
> Steps to reproduce:
> - Open dive planner
> - Insert depth for first segment
> - tab to next field
> - insert time
> - tab to next field - at this point the dive appears in the divelist
> * hit either esc or ctrl-c
> => The planner is closed but dive remains on the divelist
> At first glance the delete_single_dive is called properly with correct
> parameters, but apparently something is still not right. It is also
> notable that if you tab until on the next depth field, the delete from
> keyboard succeeds...

That's somewhat surprising. If delete_single_dive is called the dive
should be gone.

Since the problem is easily solved (by manually deleting the dive, I'd
also put this on the "investigate && fix after 3.0" list...


More information about the subsurface mailing list