[PATCH] gtk-gui.c: Move the download dialog related code to a new file
dirk at hohndel.org
Thu Jan 10 09:36:33 PST 2013
Sorry it took me so long to get back to you...
"Lubomir I. Ivanov" <neolit123 at gmail.com> writes:
> i've added a new file callbacks-gtk.h (naming scheme from display-gtk.h).
> but i've kept the SCREEN_ prefix for the two macros, since this file can be used
> by other dialogs in the future - e.g. a similar macro from print.c can
> be moved here.
I really dislike the SCREEN_ prefix.
Also, the patch seems to have DOS line ends for the new files...
But overall I think this is a good idea!
Would you like to take another stab at it?
> yeah, i also see potential for the nickname code to be moved to
> nicknames.c, given we have the UI.
> perhaps both the "backend" + UI.
Well, Linus moved some of that code around already.
Amit is working on the nickname edit UI and had played with putting that
in its own file but it just wasn't enough code. Maybe it can now go into
the device.c file to be with the related backend code...
More information about the subsurface