Use proper helper functions for dive location and for_each_dive

Linus Torvalds torvalds at linux-foundation.org
Tue Jan 22 21:26:53 PST 2013


This makes the code use the "dive_has_location()" function rather than
check the longitude and latitude directly.

It also uses "for_each_dive()" rather than open-coding it.

Signed-off-by: Linus Torvalds <torvalds at linux-foundation.org>

---
On Tue, Jan 22, 2013 at 9:03 PM, Dirk Hohndel <dirk at hohndel.org> wrote:
> Linus Torvalds <torvalds at linux-foundation.org> writes:
>
>> On Tue, Jan 22, 2013 at 8:37 PM, Linus Torvalds
>> Actually, do
>>
>>         if (dive && dive_has_location(dive))
>>
>> instead. Prettier that way,
>
> Too late. Send a patch.
>
> /D
-------------- next part --------------
A non-text attachment was scrubbed...
Name: patch.diff
Type: application/octet-stream
Size: 1393 bytes
Desc: not available
URL: <http://lists.hohndel.org/pipermail/subsurface/attachments/20130122/81cf2a14/attachment.obj>


More information about the subsurface mailing list