irda on mac

Massimiliano Gargani mgargani at
Thu Jun 6 12:06:11 PDT 2013


Never used a vm with Linux to download dive logs from Galileo or smart com, but I use with no problem an XP and it work flawlessly with subsurface, smart trak, diving log and jtrak. 

Jtrak works well under Mac but is so ugly that I don't want use it. 

My dongle is the uwatec dongle based on signatel STIR42xx

I believe it should work also with Linux. 

In next days I'll check and let you know 


Inviato da iPhone

Il giorno 06/giu/2013, alle ore 20:33, William Perry <wmperry at> ha scritto:

> I'm giving serious thought to picking up a Raspberry Pi and a case and just having a daemon that notices when the galileo comes within range, downloads the data, and emails a binary dump or a UDDF file to me for importing on my Mac.  Would certainly be cheaper than buying a new dive computer.  Are there any other computers that libdivecomputer supports that do NOT work on the mac where something like this might be useful?
> Massimiliano - if you do try to go the linux virtual machine route I would be VERY interested in your results.  I tried this last month with 4 different irda adapters using VMWare Fusion, VirtualBox, and Parallels using both Fedora and Ubuntu with no joy.  But running the same Ubuntu / libdivecomputer builds on a physical machine worked just fine, and using my normal irda adapter in a Windows VM worked as well.  If you can get it working in a VM, it would point to something screwy on my machine - I had drivers for this irda adapter installed ages ago, wondering if some remnant of that is screwing things up for me.
> -bill
> On Jun 6, 2013, at 3:26 AM, Jef Driesen <jefdriesen at> wrote:
>> On 2013-06-05 15:08, Massimiliano Gargani wrote:
>>> I own some Uwatec computer and I use mac, very bad couple.
>>> I have a IRDA USB dongle that works fine if I use JTrak but I cannot
>>> use any other divelog program under Mac because when I connect the
>>> irda dongle no /dev is created so I cannot set the device to use for
>>> download in SubSurface.
>> That's normal. IrDA communication uses sockets, and a device node isn't necessary at all. But that's the least of your problem.
>>> The dongle is base on Sigmatel STIR42xx. Sigmatel exists no more and I
>>> have a very old version of the driver I think is 32bit only and OS X
>>> 10.8 is 64bit only.
>>> I tried also on OS X 10.6 and 10.7 with no luck.
>>> Anybody knows if there is a way to use Mac+SubSurface to download
>>> dives from Uwatec computer?
>> Unfortunately Mac OS X does not have a built-in IrDA stack (unlike Windows and Linux). Therefore, all dive computers using IrDA are not supported on Mac OS X. This is unlikely to change in the future.
>> The only way to support IrDA on the Mac is to talk directly to infrared chipset and implement the IrDA protocol on top of that. This is far from trivial (IrDA is fairly complex) and would only work for that specific chipset. This is simply out of scope for the libdivecomputer project (which is the library used by subsurface for downloading dive computers).
>> You might be interested in Dive Log Manager, which has done the above and supports the Uwatec on Mac OS X, provided you have a dongle with the "right" IrDA chipset:
>> An alternative is to download your Uwatec dive computer from inside a Windows or Linux virtual machine, and then copy the data back to your Mac host.
>> Jef
>> _______________________________________________
>> subsurface mailing list
>> subsurface at

More information about the subsurface mailing list