unable to complete cross-building on fedora 20

Lakshman acrlakshman at gmail.com
Thu Apr 10 12:05:34 PDT 2014

On Thu, Apr 10, 2014 at 11:51 AM, Alberto Corona <alberto at 0x1a.us> wrote:
> On 2014-04-09 22:52, Lakshman wrote:
>> 2) I tried building "marble" following lines 204-211 of "INSTALL"
>> file. When I ran "mingw32-cmake -DCMAKE_BUILD_TYPE=Debug -DQTONLY=TRUE
>> ../sources" I got the following error:
>> /usr/bin/mingw32-cmake: line 70: fg: no job control
>> I have no idea about this error and how to resolve this, tried
>> googling, but attempts were in vain.
>> 3) Similar error i.e. "/usr/bin/mingw32-cmake: line 70: fg: no job
>> control" was thrown when I tried to run "mingw32-cmake .." for libgit2
>> (line 218 of INSTALL"
> I've never had a no job control error, where were you trying to build
> marble and libgit2? I think the INSTALL suggests creating a build directory,
> which I would suggest. You might hit a couple more bumps trying to cross-
> compile, I remember having issues where one of the ssl dlls weren't being
> included when running the packaging script in packaging/windows
That was my mistake. I didn't install cmake, now got things moving.

I could build libgit2 as was guided in the INSTALL file. However I am
unable to complete building "marble", here are the errors I am
getting, looks like I need to add something into the environment
variables, but unable to figure out how to resolve this, can someone
help me with this issue.

When I did "mingw32-cmake -DCMAKE_BUILD_TYPE=Debug -DQTONLY=TRUE
../sources/" from marble/build/ directory, I get the following error:

CMake Warning at /usr/share/cmake/Modules/FindQt4.cmake:659 (message):
  /usr/bin/qmake-qt4 reported QT_INSTALL_LIBS as "/usr/lib64" but QtCore
  could not be found there.  Qt is NOT installed correctly for the target
  build environment.
Call Stack (most recent call first):
  CMakeLists.txt:255 (find_package)

CMake Error at /usr/share/cmake/Modules/FindQt4.cmake:664 (message):
  Could NOT find QtCore.  Check
  /home/lakshman/src/marble/build/CMakeFiles/CMakeError.log for more details.
Call Stack (most recent call first):
  CMakeLists.txt:255 (find_package)

I do have qt installed, I could run a sample qt code successfully,
which could link to QtCore. But while cross-building I got the above
error. Can someone direct me where I am going wrong and provide hints
of what to do to resolve this.

Thank you,

More information about the subsurface mailing list