Shearwater Petrel Download Bug

Jef Driesen jefdriesen at
Thu Jan 16 12:37:42 UTC 2014

On 16-01-14 13:43, Tommi Saviranta wrote:
> On Wed, Jan 15, 2014 at 12:05:07 +0100, Jef Driesen wrote:
>> I have no idea why "bind" doesn't work for you.
> Neither do I. I bind my Petrel's address in rfcomm.conf and that has
> always worked flawlessly until recently. libdivecomputer clearly isn't
> to blame because the Debian package I use was last updated July. Bluez
> was last updated in December. The Linux kernel has also changed, but
> somehow I'd like to blame Bluez. In any case, I now get this (with
> rfcomm bind):
> ERROR: Transport endpoint is not connected (107) [in serial_posix.c:573
> 	(serial_write)]
> ERROR: Failed to send the request packet. [in shearwater_common.c:279
> 	(shearwater_common_transfer)]
> Running rfcomm connect manually works. rfcomm bind still works nicely on
> my N900, but that environment hasn't changed much.
> With rfcomm bind, Petrel now stays in waiting for pc state whereas with
> rfcomm connect it's clearly indicated that the connection has been
> established. Perhaps I should try an older version of Bluez when I get
> home.

I can confirm Tommi's problem on Ubuntu 13.10 (with vanilla kernel 3.12). With 
"bind" communication fails, and with "connect" it works.

I tried adding a delay of several seconds between open the /dev/rfcommX and 
sending the first packet, and this appears to work too.


More information about the subsurface mailing list