Aeris F10v2 issues

Jef Driesen jef at
Wed Jun 18 23:36:19 PDT 2014

On 2014-06-18 21:18, Gabriel Rossetti wrote:
> On Tue, Jun 17, 2014 at 12:43 PM, Jef Driesen <jef at>
> wrote:
>> On 2014-06-17 12:08, Gabriel Rossetti wrote:
>>> On Jun 17, 2014 10:46 AM, "Jef Driesen" <jef at> 
>>> wrote:
>>>> The logfile indicates a high number of failed packets. These should
>>>> disappear if you upgrade to a development build of libdivecomputer
>>>> (v0.5.0-devel). It will also make the download much faster.
>>>> I don't see any fatal errors in the log, so I assume that when you 
>>>> say
>>>> "nothing happens", you mean no dives are downloaded? To be able to
>>>> investigate this, you'll need to send a libdivecomputer memory dump.
>>>> There
>>>> is an option for this in the subsurface download dialog.
>>> Thanks, I will try that.
>>> When I said it does nothing I meant the progress bar does not move, 
>>> no
>>> dives are downloaded.
>>> I did check the dump option but it dumped nothing, the file wasn't 
>>> even
>>> created.
>> That's strange. Normally that should only happens when there is an 
>> error
>> during the download. To rule out any subsurface problems, can you try 
>> the
>> libdivecomputer test application:
>> wget
>> chmod +x universal
>> ./universal -v -l atom2.log -m atom2.bin -b atom2 <serialport>
> I ran that and attached the output. I also re-tried subsurface after 
> having
> updated my kernel and rebooted but it does the same.

I don't see anything wrong with your data. I can download 62 dives. Note 
that if you enable the libdivecomputer dump feature, no dives will be 
downloaded. This is expected. Normally you should always leave this 
feature disabled. It's only intended for troubleshooting.

As I expected, the large number of packet errors are no longer present 
in the logfile from the test application. So once you have subsurface 
version built against a newer libdivecomputer version, they should 
disappear in subsurface too.


More information about the subsurface mailing list