Stuck making Subsurface on Mac

Dirk Hohndel dirk at hohndel.org
Fri May 23 08:32:34 PDT 2014


On Fri, May 23, 2014 at 08:04:52AM -0700, Steve Ratts wrote:
> Hi,
> 
> I've been trying for several days now to get Subsurface to make on my
> Hackintosh running OSX 10.9.2. Along the way I've had to find some
> workarounds when the instructions on the Subsurface website didn't work out
> for me. Where I am now is at Step 6 (Compile Subsurface), trying to execute
> the make command. When I do this, I get the following error.
> 
> make: *** No rule to make target
> `/Users/Steve/src/subsurface/Documentation/user-manual.html', needed by
> `Subsurface.app/Contents/Resources/share/Documentation/user-manual.html'.
>  Stop.

This is one that I still haven't figured out how to solve. The
dependencies look right to me, but the qmake created Makefile still
doesn't work.

Here's what permanently fixes it:

cd Documentation
make
cd ..

You only need to do that once.
>From now on the make will succeed.

> 4. Installing Marble I ran into two issues. First the cmake command
> reported that I didn't have QTDBUS, and second, there was a hitch wrt the

That's good. You don't want to run dbus :-)

> instructions and the directories things go in. Regarding the directory
> issue I found that if I followed the step to 'cd src/lib' the 'make -j4'
> command would error out. I needed to go down one more directory into
> src/lib/marble to get it to work. Is this a possible typo in the
> instructions?

I haven't tried this in a while - this used to work.

> At this point I pressed on following the Subsurface install instructions,
> but later on I did go back to resolve the missing QTDBUS issue. The
> remainder of the steps listed under 'Install Marble' appear to have
> completed without error.

Don't. It really isn't needed.

> 5. I believe I got libdivecomputer installed correctly. There were no
> apparent errors following those steps.
> 6. When I got to the step to install Subsurface that's where I found that I
> was missing libgit2. At this point I went back to see if I could get QTDBUS
> and libgit2. What I did was this:
> 
> cd /usr/local/Cellar/
> brew install qt --with-d-bus
>    Warning: qt-4.8.6 already installed
> brew uninstall qt
>    Uninstalling /usr/local/Cellar/qt/4.8.6...
> brew install qt --with-d-bus

Really. Don't.

> That seemed to work, so I went back and followed the steps for installing
> Marble again so that it would pickup QTDBUS. That also appeared to work.
> Just for good measure, I redid the install on libdivecomputer too.

Unnecessary - libdivecomputer is completely independent from Qt

> I then installed libgit2 by executing 'brew install libgit2'. That also
> appeared to work.

Good. Which version of libgit2 got installed?

> Which brings me to where I am now. Stuck trying to do a Make on Subsurface.
> 
> Any clues?

See above :-)

> Should the install instructions be updated so that folks pick up QTDBUS and
> libgit2?

No and yes.

> Is there a typo in the Mable instructions regarding the directories, or is
> that just some idiosyncrasy of my Hackintosh runing OSX 10.9.2?

I don't know, I need to find the time to experiment with that.


/D


More information about the subsurface mailing list