Stuck making Subsurface on Mac

Steve Ratts steveratts at
Sat May 24 08:05:25 PDT 2014

Yes, you definitely have two more testers! My buddy (Darell) and I are both
very technically oriented guys who enjoy working on problems like this. I
believe Darell only or primarily uses Windows machines; but he's very
technically savvy (he builds and operates electrical testing equipment for
a living). I'm an engineer with coding experience under linux, but none
working with gui based apps, and obviously I use both Windows and OSX.

Are you serious that Uemis intends to offer a rebranded Subsurface log
software? I'm sorry, I can't tell if you're kidding or not, and I'm curious
how much help they've been in your effort to get the SDA working with
Subsurface. I would imagine that having them working on this with you would
be a help - surely they have insights into their own equipment. I've always
had the impression that they want to somehow own the social networking
aspect related to dive logs and such. Hence their MyUemis site, etc. The
trouble is their web interface is so incredibly kludgy for editing dive
info. Have they seen the light and realized Subsurface can do that so much

If you wouldn't mind, I'd very much like to know more about the problem
with the SDA file system getting full while downloading dives. In my
experience, when the SDA file system choked it wasn't possible to see if
any dives had downloaded. It seemed as if every time we cycled the power
and began again we were starting from the same place, and so were doomed.
Was that just a bug in 4.0? If so, why didn't rolling back to 3.0.2 work
for us? If it's possible, I'd like to see Subsurface gain a more robust
ability to inform the user what it's downloaded at each step so that the
user can know for sure that they're making progress.


On Sat, May 24, 2014 at 7:24 AM, Dirk Hohndel <dirk at> wrote:

> On Fri, May 23, 2014 at 11:15:32PM -0700, Steve Ratts wrote:
> > Oh, well a buddy of mine and I both have the Uemis Zurich SDA and we've
> > both had a devil of a time getting it to download lately. My buddy's
> > experience is a little different than mine, but ultimately it's still
> > similar.
> Excellent. TWO more testers :-)
> > At first, I had no trouble downloading dives and thought it worked
> > perfectly. In fact I persuaded my buddy to give Subsurface a try
> primarily
> > on this one major capability (I don't know anyone who likes the Uemis
> > web-based dive log, but then I only know three people using the SDA and
> > that includes you, Dirk.)
> Yes, the web system they have is terrible. They will soon offer their own
> divelog software - a rebranded version of Subsurface :-)
> > When my buddy tried out downloading in Subsurface he immediately ran
> into a
> > problem and was unable to get any dives downloaded. The SDA would appear
> to
> > connect, but no dives would download, and he'd get the dreaded out of
> > memory error which has been described in the Subsurface manual. This past
> > February he and I went to Bonaire with some friends and we both worked on
> > the issue together. At that time I had about 100 dives logged in the SDA
> > and he had closer to 200. I had been downloading them steadily as I went,
> > so never needed to download more than a dozen or so. One theory we had
> was
> > that since he had so many more dives logged in his SDA than I did, that
> > might be the cause of the problem. However at the time I was using
> > Subsurface 3.0.2 and he was using 4.0. I tried upgrading to 4.0 to see if
> > that was the source of the problem and immediately I lost the ability to
> > download dives.
> Yes, there was a really stupid bug in 4.0 that is fixed in 4.1 - but it
> affected only Windows systems, which is why I never saw it (as I usually
> have no Windows machine to test with (and neither does Linus)).
> > FWI, he and I were both using Windows based laptops for
> > this. I tried rolling back to 3.0.2, but it was no use, I had lost the
> > capability to download. We tried just about everything we could think of,
> > but had no luck. Eventually I was able to regain the capability, but only
> > after I got home, download my SDA using 3.0.2 on my hackintosh, and then
> > ported the dive log over to the Windows laptop. Incidentally, he was
> > eventually able to get his log into Subsurface too, but it was extremely
> > difficult. I'd have to go back and review email to see what finally did
> the
> > trick for him.
> I'm so sorry - you guys should have reported this back then and hopefully
> I would have figured out the bug earlier.
> > One thing I would really really like is a capability to output a
> diagnostic
> > log during the SDA download step so that at least I could see how far it
> > got and where i hangs. Subsurface claims to be able to do this, but AFAIK
> > this capability does not actually work.
> It only works for dive computers where we use libdivecomputer to download.
> I guess I need to implement this for the Uemis SDA as well. :-/
> > Also, I've noticed that if there is
> > one good thing about the Uemis web-based divelog it's that it can
> download
> > essentially any number of dives without choaking and hitting this out of
> > memory error (SDA file system full) that Subsurface often hits.
> No that is not true. This is a hardware limitation. Depending on how long
> your dives are, it can download about 60 dives in one setting - just like
> Subsurface. But you never run into the problem as almost no one does 60
> dives before they first connect to their web system.
> But this is indeed a design limitation of the software on the SDA. And I
> have been able to reproduce the problem with their web software as well.
> Only the web software gives you a really bogus "timeout" error message -
> but you still need to disconnect and reconnect the SDA in order to reset
> the file system (I can explain what is really happening if you are
> curious).
> > I would
> > like to look into that to see if it's possible to improve the Subsurface
> > download process. Those Uemis guys, as insane as they may be, are doing
> > something right if they can reliably get the SDA to download any number
> of
> > dives without choking.
> See above. I am 100% certain about this.
> > I'm sorry, but looking at what I've wrote, I don't think it offers much
> > concrete to describe the problem. It's late here, but I'll go back into
> my
> > email to see if I can find something more specific about what was going
> > wrong.
> No worries, this was really useful.
> > In any event, it's great to know there are allies out there with SDA's,
> and
> > that you and Linus are among them. The SDA is a great computer!
> I love it - even though I have about a dozen dive computers at my
> disposal, the SDA is still the one that I usually "dive" (i.e., even when
> diving with three or four or more computers, like I usually do, the SDA is
> the one that I pay attention to). The exception is of course when I do
> trimix dives - sadly they never implemented that.
> /D
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list