Shearwater Petrel Bluetooth connection on Fedora 20

Anton Lundin glance at
Sun Apr 12 07:58:30 PDT 2015

On 12 April, 2015 - Rick Walsh wrote:

> Hi,
> I dived with my new Shearwater Petrel 2 today, and tried downloading
> the dives to Subsurface.  Unfortunately, it didn't work, on a
> reasonably old laptop running Fedora 20 with KDE4.
> I followed the directions in Appendix B of the manual to pair a
> Bluetooth device, and bound the Petrel MAC to /dev/rcomm0.  However, I
> cannot download the dives.  The saved libdivecomputer log is:
> INFO: Open: name=/dev/rfcomm0
> INFO: Configure: baudrate=115200, databits=8, parity=0, stopbits=1,
> flowcontrol=0
> INFO: Timeout: value=3000
> INFO: Sleep: value=300
> INFO: Flush: queue=3, input=0, output=0
> INFO: Write: size=8, data=FF010400228010C0
> INFO: Read: size=0, data=
> ERROR: Failed to receive the response packet. [in
> shearwater_common.c:314 (shearwater_common_transfer)]
> ERROR: Failed to read the serial number. [in shearwater_petrel.c:169
> (shearwater_petrel_device_foreach)]
> ERROR: Input/output error (5) [in serial_posix.c:655 (serial_write)]
> ERROR: Failed to send the request packet. [in shearwater_common.c:297
> (shearwater_common_transfer)]
> ERROR: Input/output error (5) [in serial_posix.c:202 (serial_close)]
> I tried with both the onboard Bluetooth card, as well as the USB
> Bluetooth dongle that came with the Petrel.  Same result with either
> controller.

I have had some bluetooth problems to, but with a separate
el-cheepo-dongle everything started to run smoothly.

Looks like you don't get any working connection to your Petrel.

My tips are:

Use rfcomm connect instead of bind. Watch the command and make sure the
rfcomm channel have connected before starting any communication over it.

Make sure you gave rfcomm -i [hciX|bdaddr] the right device as your
"source". Eg. by default it uses hci0 on my machine, the built in
problematic device.


Anton Lundin	+46702-161604

More information about the subsurface mailing list