problems compiling subsurface 4.4 on fedora 18

Lubomir I. Ivanov neolit123 at gmail.com
Mon Feb 16 17:09:21 PST 2015


On 17 February 2015 at 02:58, Michele Fabi <fabiemme at gmail.com> wrote:
>>
>> hello,
>>
>> Qt4 is no longer supported by Subsurface.
>> you should install the Qt5 developer packages and use the appropriate
>> Qt5 qmake command to build the application.
>>
>> lubomir
>> --
>
>
> Thank you for your quick reply. To tell the truth I already tried to compile
> with qmake-qt5, but it doen't work:
>
> [michele at localhost subsurface]$ qmake-qt5
> [michele at localhost subsurface]$ make
> Checking /home/michele/subsurface/ssrf-version.h
> compiling main.cpp
> In file included from qt-ui/simplewidgets.h:13:0,
>                  from .uic/ui_mainwindow.h:25,
>                  from qt-ui/mainwindow.h:15,
>                  from main.cpp:11:
> .uic/ui_renumber.h: In member function ‘void
> Ui_RenumberDialog::retranslateUi(QDialog*)’:
> .uic/ui_renumber.h:79:97: error: ‘UnicodeUTF8’ is not a member of
> ‘QApplication’

seems to me like old files generated by Qt4 remain in the .uic folder.
try running:

qmake-qt5
make clean
make

lubomir
--


More information about the subsurface mailing list