[libgit2] Compile issue on debian-unstable

Miika Turkia miika.turkia at gmail.com
Fri Feb 20 10:51:47 PST 2015

On Fri, Feb 20, 2015 at 8:17 PM, Willem Ferguson <
willemferguson at zoology.up.ac.za> wrote:

>  On 19/02/2015 07:02, Miika Turkia wrote:
>> As supossed, I had a v0.20.0  version built from scratch overlaped with
>> the debian package. Cleaned it and the macro worked fine as debian version
>> (v0.21.3) has three parameters defined .
>>  I think the wrapper was set to support three parameters because v0.21
>> (at least the one packaged in debian) had only those 3 and fourth was
>> introduced  later.  But agree with you  3 completely different versions of
>> the same library function in less than a  year is a mess  (saying it smooth
>> and politely).
>>   On Ubuntu Utopic (14.10) I also have the problem with only 1 parameter
> for git_remote _fetch
>  #define LIBGIT2_VERSION "0.20.0"
>  I use the attached patch on my tree, but never sent it out as I have no
> clue about how the libgit versioning/API works.
> miika
>  I was away for two weeks and got out of touch with respect to the mess
> with libgit2. I run Ubuntu 14.4 and the default version of libgit-dev is
> V19.
> Does the latest Subsurface master run with libgit2 V19? The first #if in
> that file appears to provide for this
> but I get make errors as discussed previously on this forum. Upon
> applying Miika's patch (above, to git-access.c), I get the following:
> .obj/git-access.o: In function `is_git_repository':
> git-access.c:(.text+0x327): undefined reference to `git_remote_fetch'

Looks like this function was introduced on 0.20.0.

> Is there a sane solution for Debian/Ubuntu?

Try the attached patch. At least it should allow you to compile again.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20150220/18380463/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-Fix-compile-for-distros-with-older-libgit2.patch
Type: text/x-diff
Size: 1631 bytes
Desc: not available
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20150220/18380463/attachment.patch>

More information about the subsurface mailing list