[QtBluetooth] Help for testing HW_OSTC3 and SHEARWATER families

Rick Walsh rickmwalsh at gmail.com
Wed Jul 8 15:18:01 PDT 2015

Hi Anton,

On 9 Jul 2015 7:35 am, "Anton Lundin" <glance at acc.umu.se> wrote:

> Chokay. I tried to test against a OSTC Sport, and got some results.
> Fist off i got massively de-railed due to that somehow i got
> CONFIG_BT_BCM enabled in my kernel which caused btusb to fail its
> dependency on btbcm like:
> Bluetooth: hci0: BCM: Read verbose config info failed (-16)
> and thus not really create a working bt device.
> Still hciconfig showed a hci0 but with mac 00:00... and the device didn't
> Then i tried to scan for the OSTC Sport and came up empty, and
> remembered the fact that this MacBookPro8,2 has a crappy wifi/bluetooth
> interaction when running Linux so the bt device is basically useless.
> So, i brought out my old trusty usb-bt stick that i normally use, and
> noted that i couldn't switch adapter in the bluetooth dialog. I can
> power down the internal bluetooth thingie but its still there so
> subsurface just shows that one.
> It would be great if there was a way to switch to using another bt
> device on your host.

I agree, that would be great.  But on my computer at least, if I boot it
with a bluetooth usb dongle plugged in, then the dongle rather than onboard
bluetooth is hci0.  If yours is the same, that might let you test the bt

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20150709/a97d2682/attachment.html>

More information about the subsurface mailing list