[PULL REQUEST] GSoC Printing: part 4

Dirk Hohndel dirk at hohndel.org
Mon Jul 20 06:34:03 PDT 2015

On Mon, Jul 20, 2015 at 04:29:50PM +0300, Lubomir I. Ivanov wrote:
> On 20 July 2015 at 16:22, Dirk Hohndel <dirk at hohndel.org> wrote:
> > On Mon, Jul 20, 2015 at 03:48:32PM +0300, Lubomir I. Ivanov wrote:
> >> Part 4 of the new GSoC printing module from Gehad.
> >
> > I merged this.
> >
> >> ATM this is useable, but the stock templates aren't pretty yet; an important
> >> thing on the TODO list is to get the already present templates to look similar
> >> to what we in the previous print module (i.e. user-ready).
> >
> > Yes, the templates are really ugly :-)
> > But my biggest issue is that on my system (ArchLinux) I don't get any
> > useful text at all. It looks like all the text boxes are compressed into
> > thin orange lines. I can tell from the samples that Gehad sent that this
> > isn't how it is supposed to look... any idea what's wrong here?
> >
> seems to happen due to a font size of 0.
> i've already complained about that and Gehad said that i need to
> delete the local QSettings group (e.g. registry key on windows).
> once i've deleted the QSettings group and started Subsurface again the
> default font size of 9 worked as expected.
> not 100% sure why it happens but users should not encounter the issue.

Yeah, that's an interesting set of settings I have there:


Removing that fixed it.
Adding some special handling that refuses to accept a font_size of 0 might
not be a bad idea, but since regular users won't run into this (I assume
this is the result of a buggy intermediate version I must have tried?) I'm
not to concerned.

Thanks for the quick response


More information about the subsurface mailing list