Petrel 2 Download

Anton Lundin glance at
Wed May 20 03:48:36 PDT 2015

On 20 May, 2015 - Rick Walsh wrote:

> Thanks for the suggestion but still no luck.  I tried rfcomm0,
> rfcomm1, rfcomm2 and rfcomm3.  All give:
> Can't connect RFCOMM socket: Connection refused

Thats not the rfcomm channel, its only which rfcomm device node you will
bind the channel to. The rfcomm channel syntax is:
rfcomm connect  <dev> <bdaddr> [channel]

I'd brute force the available ones from 1 to 31 and test. Usually rfcomm
have guessed (or assumed as 1?) the right one for me.

> I tried sdptool browse 00:13:43:0E:6B:D0 (after pairing was
> successful).  It gives a message saying it's opening or reading the
> device (I'm at work now and don't have the exact output).  Monitoring
> what's happening with bluetoothctl running on a separate terminal
> indicates it is attempting to connect, but drops it after a second or
> less - same as when attempting to connect within bluetoothctl or with
> rfcomm:
> [CHG] Device 00:13:43:0E:6B:D0 Connected: yes
> Failed to connect: org.bluez.Error.NotAvailable
> [CHG] Device 00:13:43:0E:6B:D0 Connected: no
> I think I'll try finding a live distro tonight with Bluez version 4,
> rather than version 5 I'm currently using, to see if that helps.
> Googling suggests many people have had issues with 5.

I've only run the bluez4 stack. I've run it on ubuntu 15.04 as late as
of Sunday against my OSTC Sport.


Anton Lundin	+46702-161604

More information about the subsurface mailing list