Crash Mobile build 758 on Android 5.1.1

David Tillotson david at
Sun Jan 31 13:37:18 PST 2016

On Sun, 31 Jan 2016 13:24:30 -0800
Dirk Hohndel <dirk at> wrote:

> > Files in the attached, created with 758 (a clean re-install, and
> > still behaving the same way.) A quick look through the files
> > doesn't reveal anything that I can see, but there's obviously
> > something odd somewhere in there.
> Nothing in the ssrf file looks suspicious (except for the water
> temperature... that's VERY suspicious... that's about 25 degrees too
> cold...)

Ha, that's the kind of thing we need to tolerate over here! I must
admit, it is easier in the warmer climes though. I actually plan on
doing Silfra next year, and if there's anyone cares to join me, we
could make it a Subsurface users' meet ;-)

> > > > Oddly, the edit button is now non-functional, rather than
> > > > randomly functional.
> > > 
> > > I guess consistency and deterministic behavior is an improvement.
> > > It makes it much more likely that we can debug and fix this.
> > 
> > I obviously didn't try enough the first time. When testing again, I
> > got the edit to work after 3 presses, and the cancel after 8. Next
> > time round took >20 presses - I've included a logcat file for edit
> > mode in the attached, but again, there's nothing leaps out.
> I can't spot the crash in the crash log. Hmm. Is that the right log
> file? Other than that I see a broken reference to detailsPage (easy
> enough to fix) and these odd warnings:

It struck me as odd - it just stops (with a truncated line) when the
crash occurs. Tried a number of times, always the same result.

> W/Subsurface(26343): (null):0 ((null)): This plugin does not support
> setting window opacity
> Which device / which version of Android? 

Device is a Galaxy Note 4 (Android 5.1.1 with Samsung's Touchwiz
overlay, if that could have any impact).

David Tillotson

More information about the subsurface mailing list