android package

Axel Richter Axel.Richter at freenet.de
Fri Jul 15 12:30:26 PDT 2016


Am 15.07.2016 um 06:30 schrieb Willem Ferguson:
> On 14/07/2016 20:31, Axel Richter wrote:
>> Am 12.07.2016 um 10:05 schrieb Dirk Hohndel:
>>> Yahoo's strict DMARC policies cause ...
>>
>> Hi all,
>> I'm back!
>>
>> To all: Good work, the android package still builds and 
>> runs ok.
>>
>> Axel.
> Axel,
>
> Which version/build of Subsurface?
> Which version of Qt?
> Which OS?
>
> Kind regards,
> Willem

Hi Willem,

  * OpenSuSE 13.2 as host
  * Subsurface latest git (last commit was July 9th)
  * kirigami latest git (last commit was July, 14th)
  * Qt 5.7
  * android ndk r12
  * android sdk API 21 (for Android 5.0.1 since I have a S5)
  * OpenJDK 1.8.0_91

The configuration works for building the Linux 64-bit 
subsurface and for the android apk, too. For the build I 
changed the mobile-resources.qrc and mobilecomponents.sh 
like provided in the patch I sent to you. In addition I had 
to set the JAVA_HOME to /usr/lib64/jvm/java-1.8.0-openjdk-1.8.0.

Best Regards,
Axel.




-- 
Axel Richter

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20160715/6f3b0774/attachment.html>


More information about the subsurface mailing list