Subsurface-mobile crossbuild

Willem Ferguson willemferguson at zoology.up.ac.za
Sat Jul 30 12:40:07 PDT 2016


Hallo Dirk,

For some time now I have not managed to build the Android executable, 
possibly due to conflict between Qt5.7 and Kirigami ??? (actually I have 
never managed to build the executable). See message below. For that 
reason there was no movement on USB dive import into Subsurface-mobile.

Kind regards,
willem

On 19/07/2016 00:49, Axel Richter wrote:
>
> Dear Willem,
>
> now I've tried half of the night to get a running SubSurface again on 
> my mobile - and failed. After updating to the latest git sources I was 
> able to recreate your problem. I fixed
>
>   * copying the correct qml files (no success) and then I tried
>   * with the [PATCH] WIP: use kirigami plugin instead of embedding in
>     qrc
>     <https://www.mail-archive.com/search?l=subsurface@subsurface-divelog.org&q=subject:%22Re%5C%3A+%5C%5BPATCH%5C%5D+WIP%5C%3A+use+kirigami+plugin+instead+of+embedding+in+qrc%22&o=newest>.
>     The problem here was the dependency from ECM which caused problems
>     to build (using Android.cmake).
>
> I decided to wait until the kirigami-plugin battle is gone. I am with 
> Marco using the plugin since copying the qml files was working, but 
> not the solution of choice.
>
> If I can test or do something, please let me know. I promise I'll 
> check the mails and commits in git frequently. If there are good news 
> I'll publish.
>
> Best Regards,
> Axel.
>
> -- 
> Axel Richter
>
Axel,

Thank you so much for your time. I really appreciate it.
Let us be patient and wait until the solution is found.

Kind regards,
willem



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20160730/5d94832e/attachment.html>


More information about the subsurface mailing list