Pretel dives not downloading.

Pablo Wolter pwolter at
Wed Apr 5 13:50:24 PDT 2017

Hi all,

I just tried to download 2 dives from the last weekend in Subsurface
and nothing happens. I have not downloaded dives since I upgraded to
this new version. before it worked but I have not downloaded in a

I always first pair the dive computer with my Mac. Then open
Subsurface and try to import. I click the Download on Subsurface the
button gets greyed out the computer tells me it sent data and comes
back to main screen but Subsurface doesn't do anything. After a while
the download button is blue and reads Retry, on the right the dives
list shows 2 dives and they are selected. The dive computer is back to
its main screen. I go again to Dive Log - Upload Log and click retry
.... nothing, just shows an error: Unable to open
/dev/tty.Pretel-SerialPort Sherwater (Pretel).

Log file attached. It did not make any dump of libdivecomputer on my
machine after selecting it.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: subsurface-pwolter-log-032017.log
Type: application/octet-stream
Size: 223 bytes
Desc: not available
URL: <>

More information about the subsurface mailing list