Pretel dives not downloading.

Pablo Wolter pwolter at
Wed Apr 5 21:04:08 PDT 2017

Thanks Rick. Unfortunately it did not help. Exact same issue. Weird
thing is that not even the Sherwater software can see my Pretel. Mac
pairs it without issues.

Will have to dig some more to try other things. Will elt you know if I
have success or find anything different.

On Wed, Apr 5, 2017 at 3:45 PM, Rick Walsh <rickmwalsh at> wrote:
> Hi Pablo,
> On 6 April 2017 at 06:50, Pablo Wolter <pwolter at> wrote:
>> Hi all,
>> I just tried to download 2 dives from the last weekend in Subsurface
>> and nothing happens. I have not downloaded dives since I upgraded to
>> this new version. before it worked but I have not downloaded in a
>> while.
>> I always first pair the dive computer with my Mac. Then open
>> Subsurface and try to import. I click the Download on Subsurface the
>> button gets greyed out the computer tells me it sent data and comes
>> back to main screen but Subsurface doesn't do anything. After a while
>> the download button is blue and reads Retry, on the right the dives
>> list shows 2 dives and they are selected. The dive computer is back to
>> its main screen. I go again to Dive Log - Upload Log and click retry
>> .... nothing, just shows an error: Unable to open
>> /dev/tty.Pretel-SerialPort Sherwater (Pretel).
> Many, but not all, issues with downloading from Bluetooth are solved by
> putting a new battery in your dive computer. This is especially the case
> when downloading used to work but doesn't anymore. One thing I like about
> the Petrel (and Perdix) is that replacing the AA battery is easy and cheap.
> Now I was about to say download with my Petrel 2 works fine on Linux.  But I
> just tested with the latest master, and it failed with a similar error on
> the command line, and "Insufficient privileges to open the device..." dialog
> displayed.
> qt.bluetooth.bluez: void QBluetoothSocketPrivate::_q_readNotify() 29 error:
> -1 "Resource temporarily unavailable"
> [5.125099] ERROR: Failed to open the serial port. [in
> ../../src/shearwater_common.c:46 (shearwater_common_open)]
>> Log file attached. It did not make any dump of libdivecomputer on my
>> machine after selecting it.
>> _______________________________________________
>> subsurface mailing list
>> subsurface at

More information about the subsurface mailing list