error when saving information on the cloud

Davide DB dbdavide at
Sun Apr 9 01:55:04 PDT 2017

On 8 April 2017 at 17:46, Dirk Hohndel <dirk at> wrote:
>> #1 I tried to update the 4.4.2. via help > check for updates. but I get
>> error (unable to contact server, check your internet connection...)
>> see the attachments.
> Fixed. That's the problem with running my own infrastructure. I don't
> always notice when things fall down.

OK Thanks

> This I don't quite understand. So you entered the wrong password but got
> no error at all? That sounds wrong.

This was the main culprit. I tried with another laptop and now I get the
usual red status bas message saying password mismatch. But Yesterday I saw
error messages only on system console. The UI wasn't updated at all.

>> Summarizing everything:
>> #1 There's no way to reset password by themselves. It's simply crazy but
>> lest I would expect a huge bold blinking text mentioning it on the user
>> manual.
> Yes, there is no way to do that. I don't have the time and energy to write
> something that I am comfortable won't be hacked. And given the relatively
> small user base of the cloud service (a couple thousand people), one
> request every other week doesn't kill me.

I'm confortable with this but I think is important to clearly mention this
on user manual. I discovered it searching on the mailing list.

>> #3 Global user experience on this is really a mess. Even having
>> semantically related parameters scattered on two different preference
>> (defaults/network) does not help to understand the whole picture. Of
>> I understand that for who wrote and developed the code everything is
>> but I can assure you that from a stupid user like me is not.
> I agree, the user experience could be better.
> We don't have anyone with a focus on this. If you want to help us improve
> the user experience (and no, I'm not asking you to write the code, I'm
> asking to clearly identify the problems and propose solutions) then I'm
> sure we can improve that.

>> (PLEASE Dirk could you reset my password?).
> Done

Thanks, now I finally got my logbook on the cloud (WOW).
Actually my desktop UI is still in a strange state.

Once you reset my password I opened again Subsurface expecting to be
prompted for a new password or, at least, having a clear state in the
network preference tab.
This is the system console log:

cloud URL set as "[]

File locations:

Local git storage:
cloud URL set as "[]
Cloud URL:[]
Image hashes: C:\Users\Bocio\AppData\Roaming\Subsurface/hashes
Local picture directory:

libpng warning: iCCP: profile 'ICC Profile': 1000000h: invalid rendering
Set the current dive site: 0
Completed connection with cloud storage backend, response "[OK]"

This is the UI:

[image: Inline images 1]

So I just entered a password in the (already filled) textfield and I
clicked "apply"
System console wrote:

Set the current dive site: 0
QObject::connect: No such slot
QObject::connect:  (receiver name: 'PreferencesNetwork')
Set the current dive site: 0
Completed connection with cloud storage backend, response "[PASSWDCHANGED]"
Set the current dive site: 0


Once again I open the preferences/network tab and this time I found UI

[image: Inline images 3]

I already changed my password but now I found a new textfield labeled "New

I would have expected finding something like the above state immediately
after password reset. I try to explain. Nowadays classic UI interaction
when changing a password is:

A dialog/tab/mask/window with 3 textfield:

- old/current password
- new password
- confirm new password (to validate against the password textfield)
Optionally (and welcomed) a checkbox to show entered password.

Given that Dirk already reset my password we could surely avoid the current
password texfield having only two texfields.
Finally server interaction should start only when new pwd textfields


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: network.PNG
Type: image/png
Size: 68788 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: password updated.PNG
Type: image/png
Size: 51583 bytes
Desc: not available
URL: <>

More information about the subsurface mailing list