Building iOS Subsurface-mobile

Robert Helling helling at
Mon Apr 10 14:52:09 PDT 2017


yesterday, after managing to build the mobile app on the desktop again, I decided I should try to also build the iOS version (some months ago, I was able to do that but many things happened since then). But after investing about two hour, I still fail. After fixing a few other things, when I run the in subsurface/packaging/ios I get a complaint about a missing header file

[  0%] Building C object CMakeFiles/git2.dir/src/stransport_stream.c.o
/Users/Helling/src/ios/subsurface/packaging/ios/libgit2-0.23.4/src/stransport_stream.c:10:10: fatal error: 'CoreFoundation/CoreFoundation.h' file not found
#include <CoreFoundation/CoreFoundation.h>

According to locate, I have 16 versions of a file called CoreFoundation.h on my system, but none in a directory of a similar name. Anybody any idea? Could this be due to my Mac running MacOS Sierra? Who else (besides Dirk) is currently being able to build the iOS version? Which OS version are you using? Any further ideas?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 496 bytes
Desc: Message signed with OpenPGP
URL: <>

More information about the subsurface mailing list