4.6.4-675 could use some testing

Dirk Hohndel dirk at hohndel.org
Tue Aug 1 03:12:05 PDT 2017


> On Jul 31, 2017, at 10:51 PM, Salvador CuƱat <salvador.cunat at gmail.com> wrote:
> 
> Good morning.
> 
> El 01/08/2017 06:57, "Willem Ferguson" <willemferguson at zoology.up.ac.za <mailto:willemferguson at zoology.up.ac.za>> escribiĆ³:
> >
> >
> > On my Ubuntu the AppImage crashes upon startup because of dependency
> > problems.
> >
> >   using PERLLIB=./share/perl5/:./lib/perl5/:
> >   using GSETTINGS_SCHEMA_DIR=./share/glib-2.0/schemas/:
> > can't find Qt localization for locale "en-ZA" searching in
> > "/usr/share/qt5/translations"
> > can't find Subsurface localization for locale "en-ZA"
> > qrc:/MapWidget.qml:3:1: module "QtLocation" is not installed
> > qrc:/MapWidget.qml:2:1: module "QtQuick" is not installed
> > qrc:/MapWidget.qml:4:1: module "QtPositioning" is not installed
> > qrc:/MapWidget.qml:3:1: module "QtLocation" is not installed
> > qrc:/MapWidget.qml:2:1: module "QtQuick" is not installed
> > qrc:/MapWidget.qml:4:1: module "QtPositioning" is not installed
> > qrc:/MapWidget.qml:3:1: module "QtLocation" is not installed
> > qrc:/MapWidget.qml:2:1: module "QtQuick" is not installed
> > qrc:/MapWidget.qml:4:1: module "QtPositioning" is not installed
> > MapWidget status QQuickWidget::Status(Error)
> > Segmentation fault (core dumped)
> 
I tried to install those, maybe they are in the wrong spot. I'll look some more tomorrow - err, later today.

> I get the same crash with the Qt libraries in regular Linux building. Only if built without marble.
> On Debian unstable.
> 


On a native build? Those modules should be found. Odd. 
I'm puzzled what might be missing.

Thanks for those two reports. More work to be done

/D
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20170801/599492d7/attachment-0001.html>


More information about the subsurface mailing list