Fwd: importing smarttrak slg logs

Alessandro Volpi alessandrovolpi at fastwebnet.it
Wed Feb 1 15:42:02 PST 2017

I send you again the forwarded message only to add that, after 
installing subsurface from the fedora 24 repo the libssrfmarblewidget.so 
shared object is now present in my system and that I am now able to 
launch both versions of subsurface: the version downloaded from the dnf 
repo and also the version obtained by building the apllication from the 
source. Obviously the slg import program is still missing.

Best regards.

Alessandro Volpi

-------- Forwarded Message --------
Subject: 	importing smarttrak slg logs
Date: 	Wed, 1 Feb 2017 23:20:45 +0000
From: 	Alessandro Volpi <alessandrovolpi at fastwebnet.it>
To: 	subsurface at subsurface-divelog.org

I have installed subsurface from the Fedora 24 repo and I tried running
it. It seems to be working but it does not contain the tool for
importing slg files.

The subsurface manual and the help file in subsurface say that the tool
must be built from the sources.

I have therefore built the main program from sources starting on a src
directory in /root and I have created a symbolic link to the subsurface
executable in /opt .

Launching the executable from my home directory results in a failure in
loading the shared library libssrfmarblewidget .so module; the module
seems not be existing.

I have tried building smtk2ssrf from the source tree; I was not
successful since :

1) the required libraries libglib2.0 and libmdb2 are not available for
Fedora 24 in the standard repos

2) I have no experience in using ccmake and I have not understood from
which directory should it be launched. I probably also do not understand
the meaning of :

    "Run " $ ccmake build " and set SMARTTRAK_IMPORT option to on (off
by default).
     Generate with [c] and save and exit with [g]."

Perhaps the above described operations should be completed before
building the main subsurface executable and not after having done so ...
In any case I am inclined to think that the missing libssrfmarblewidget
library is not related to the smtk2ssrf build operation.

By the way I was not able to find in the Documentation pack whether
Subsurface supports the Galileo Trimix system and the deriving .slg files.

I would be very grateful to you if you could help me in building
smtk2ssrf and in finding the required libraries.

Very best regards.

Alessandro Volpi

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20170201/25201756/attachment.html>

More information about the subsurface mailing list