Fwd: importing smarttrak slg logs

Salvador Cuñat salvador.cunat at gmail.com
Thu Feb 2 16:19:00 PST 2017

Good night Willem and  Alessandro.

On Thu, Feb 02, 2017 at 09:16:10AM +0200, Willem Ferguson wrote:
> Hi Salva,
> I think you are the best person to respond to this?
> Kind regards,
> willem
> alessandrovolpi at fastwebnet.it
> I have installed subsurface from the Fedora 24 repo and I tried running
> it. It seems to be working but it does not contain the tool for
> importing slg files.
That's ok. It must be this way because of its own dependencies.

> The subsurface manual and the help file in subsurface say that the tool
> must be built from the sources.
ATM there are no binaries for it, so building is a must.
BTW I'm working an AppImage 
> I have therefore built the main program from sources starting on a src
> directory in /root and I have created a symbolic link to the subsurface
> executable in /opt .
Hmmm. Building as root doesn't seem a good practice. It would be
better to build as a user in a directory like
/home/user/src/subsurface then installing as root.

> Launching the executable from my home directory results in a failure in
> loading the shared library libssrfmarblewidget .so module; the module
> seems not be existing.
> I have tried building smtk2ssrf from the source tree; I was not
> successful since :
> 1) the required libraries libglib2.0 and libmdb2 are not available for
> Fedora 24 in the standard repos
They are there, just with different names.  That was my fault, I
should have realized different distros use different names for their
packages. The names I wrote were those for debian and cousins. It
seems for Red Hat and friends (Fedora, CentOS, etc) these comands
should work:

sudo dnf install glib2.x86_64 mdbtools-devel (at least in Fedora 25 this
throws a versioning problem; it solves using --best --allowerasing flags)

In Debian, Ubuntu, etc, just:

sudo apt update && sudo apt install mdbtools-dev

Will bring all dependencies 

> 2) I have no experience in using ccmake and I have not understood from
> which directory should it be launched. I probably also do not understand
> the meaning of :
>     "Run " $ ccmake build " and set SMARTTRAK_IMPORT option to on (off
> by default).
>      Generate with [c] and save and exit with [g]."

Here I was supposing that subsurface had been previously build using
something like next command (assume you are in src directory)


Said script sets most cmake options and gets some subsurface
dependencies like marble, libdivecomputer, libgit2 and grantlee.
As I understand you had, then move to subsurface directory and run:

ccmake build

You need to have installed cmake-gui.x86_64 (Fedora) or cmake-curses
in Debian.

One of the options is SMARTTRAK_IMPORT and is set to OFF (default).
Change it to ON, and rebuild subsurface, using the script build.sh as
described above or moving into the directory named "build" and running

make clean && make -j4 (some times -j4 flag causes failures, perhaps
-j2 is better if you are running a powerful computer).

After a succesful build smtk2ssrf should be present in the build
directory along with subsurface binary.
> Perhaps the above described operations should be completed before
> building the main subsurface executable and not after having done so ...
> In any case I am inclined to think that the missing libssrfmarblewidget
> library is not related to the smtk2ssrf build operation.
I think you solved this yourself, it's not used by smtk2ssrf but it's
a hard dependency for subsurface.
> By the way I was not able to find in the Documentation pack whether
> Subsurface supports the Galileo Trimix system and the deriving .slg files.
Yes, Galileo Trimix is supported via libdivecomputer. slg import is
too as it is made using libdivecomputer library. In fact, I think
Willem used to dive a Galileo which was trimix upgraded (please Willem
correct me if I'm wrong). BTW, I think some warnings and alarms in
Galileo's profiles are not fully understood yet, so they are shown as
bookmarks. Not sure about this.

> I would be very grateful to you if you could help me in building
> smtk2ssrf and in finding the required libraries.
It will be a pleasure for me if I'm somehow useful.

P.D.  Willem, I'm trying to build an appimage, please try this


It throws an error on most systems I've tried, but runs on Debian and
Ubutu if Qt5 > 5.2 is properly installed. I expect to have it fully
functional by this weekend.  And it's patched to avoid the localized
time related crash Dirk had some time ago.



More information about the subsurface mailing list