Problems building Subsurface for Android

Dirk Hohndel dirk at
Fri Feb 3 20:11:43 PST 2017

Because clearly I like pain, I went through this whole thing again. And
tried to make it even more self contained, even more automatic. And
because clearly I was bored, I tested the whole thing on a freshly
installed Ubuntu 16.10.

Here are the complete steps it took me to get a working

$ sudo apt install git
$ git clone git://
$ bash subsurface/packaging/android/

(if you are missing packages, it will tell you. Install them)

$ bash subsurface/packaging/android/

Yes, the 700MB (or so) Qt download takes a while, even with a fast
internet connection.

When the Qt installer opens, the terminal will tell you which path to
enter as destination (default is ~/Qt5.7.1 but we want ~/src/Qt5.7.1 or
what ever you used as starting point -- really, it will tell you, use that

At the end, don't start Qt Creator, just keep going.

More downloads. At one point you need to accept an EULA.

Everything else should run through without any user input. In one test the
whole thing suddenly stopped. I still don't know why. Gremlins. Just
delete whatever was the last directory it was working on and restart the

In the end it will print out the full path to the APKs.

If any of this doesn't work. Send me the log file.


PS: Anton - yes, I ran this through shellcheck

More information about the subsurface mailing list