Failed to parse XML

Miika Turkia miika.turkia at
Sun Feb 19 22:14:32 PST 2017

You can send it to me and Dirk directly. It is OK to send it to the
mailing list also, but I do not remember what the size limit for the
mailing list is.


On Mon, Feb 20, 2017 at 8:05 AM, Pablo Wolter <pwolter at> wrote:
> I tried to run it with the "-v -v" but I guess that works on Linux?
> I'm on Mac and nothing happens when trying them. Do I send you my XML
> file to you or it is ok to send to the list? It's a ~4 Mb file.
> Pablo.
> On Sun, Feb 19, 2017 at 1:54 PM, Dirk Hohndel <dirk at> wrote:
>> On Sun, Feb 19, 2017 at 09:23:41PM +0000, Pablo Wolter wrote:
>>> Today I tried to download a bunch of dives from my dive computer.
>>> I opened Subsurface and got a red error frame at the bottom saying it
>>> failed parsing my local XML  file.
>>> All my dives are gone. The application is empty.
>>> I remember a while ago I saw an email exchange about something like this
>>> due a change on the internal dives storage but can't find the emails.
>>> Do you remember how to solve this? Yes. I have not dived in a while .....
>> First thing to do... copy the XML file and the .bak file of the same name
>> to a different directory... just to be on the safe side.
>> Then... either run subsurface -v -v from the command line to see if you
>> can make sense of what's going on, or send the XML file to some of us so
>> we can take a look. Usual suspects would be Linus, Miika, and myself. I'm
>> sure between the three of us we can figure out what's going on.
>> For the record. We have every intention to have this NEVER happen.
>> Subsurface is supposed to ALWAYS be able to read older files. So I'd love
>> to figure out what's wrong, fix it, create a test for it... and then all
>> of that will make it into 4.6.3 :-)
>> (unless of course it's a random file corruption - we've seen those as well)
>> Thanks
>> /D
> _______________________________________________
> subsurface mailing list
> subsurface at

More information about the subsurface mailing list