Failed to parse XML

Pablo Wolter pwolter at
Sun Feb 19 22:37:11 PST 2017

Thanks Mika, that solved it. I may have typed some weird characters
close by like " " ", " ' ", ">", "." or "?" instead of "/". Or I
really don't know what happened.

Works now. Thanks!


On Sun, Feb 19, 2017 at 10:24 PM, Miika Turkia <miika.turkia at> wrote:
> A quick fix: delete the contents of the notes on line 39 (USA /
> Mukilteo / State Park, site uuid 2e3add63). That contains some
> encoding we do not understand. Input files should be UTF-8 for them to
> work properly.
> miika
> On Mon, Feb 20, 2017 at 8:14 AM, Miika Turkia <miika.turkia at> wrote:
>> You can send it to me and Dirk directly. It is OK to send it to the
>> mailing list also, but I do not remember what the size limit for the
>> mailing list is.
>> miika
>> On Mon, Feb 20, 2017 at 8:05 AM, Pablo Wolter <pwolter at> wrote:
>>> I tried to run it with the "-v -v" but I guess that works on Linux?
>>> I'm on Mac and nothing happens when trying them. Do I send you my XML
>>> file to you or it is ok to send to the list? It's a ~4 Mb file.
>>> Pablo.
>>> On Sun, Feb 19, 2017 at 1:54 PM, Dirk Hohndel <dirk at> wrote:
>>>> On Sun, Feb 19, 2017 at 09:23:41PM +0000, Pablo Wolter wrote:
>>>>> Today I tried to download a bunch of dives from my dive computer.
>>>>> I opened Subsurface and got a red error frame at the bottom saying it
>>>>> failed parsing my local XML  file.
>>>>> All my dives are gone. The application is empty.
>>>>> I remember a while ago I saw an email exchange about something like this
>>>>> due a change on the internal dives storage but can't find the emails.
>>>>> Do you remember how to solve this? Yes. I have not dived in a while .....
>>>> First thing to do... copy the XML file and the .bak file of the same name
>>>> to a different directory... just to be on the safe side.
>>>> Then... either run subsurface -v -v from the command line to see if you
>>>> can make sense of what's going on, or send the XML file to some of us so
>>>> we can take a look. Usual suspects would be Linus, Miika, and myself. I'm
>>>> sure between the three of us we can figure out what's going on.
>>>> For the record. We have every intention to have this NEVER happen.
>>>> Subsurface is supposed to ALWAYS be able to read older files. So I'd love
>>>> to figure out what's wrong, fix it, create a test for it... and then all
>>>> of that will make it into 4.6.3 :-)
>>>> (unless of course it's a random file corruption - we've seen those as well)
>>>> Thanks
>>>> /D
>>> _______________________________________________
>>> subsurface mailing list
>>> subsurface at

More information about the subsurface mailing list