keyboard shortcuts

Dirk Hohndel dirk at
Wed Feb 22 07:48:23 PST 2017

On Wed, Feb 22, 2017 at 01:31:53PM +0200, Miika Turkia wrote:
> On Wed, Feb 22, 2017 at 1:10 PM, Robert Helling <helling at> wrote:
> > Jan,
> >
> > On 22.02.2017, at 11:58, Jan Mulder <jlmulder at> wrote:
> >
> > Like other functions that can be accessed via the Main Menu, these options
> > can also be triggered using keyboard shortcuts. The shortcuts for a
> > particular system are shown with an underline in the main menu entries.
> > Since different Operating Systems and the user’s chosen language may cause
> > Subsurface to use different shortcut keys, they are not listed in this user
> > manual.
> >
> >
> > This is definitely not true in the current master (checked on Linux and
> > Windows 7). However, in the menus, keyboard shortcuts are printed for often
> > used functions. So, what I'm unsure about, is this an error in de manual or
> > in the code?
> >
> >
> > I do not completely understand your question. Is your statement there are
> > underlines in the menu and the manual is silent about shortcuts?
> On my Ubuntu, the menu items indicate the shortcut by underlining the
> appropriate character. Within the menu, the shortcuts are given in the
> form: ctrl+i (for import).

The odd thing is that we have two "levels" of shortcuts and that's what's

One are the official shortcuts (Ctrl-D to download, Ctrl-L to plan =
substitute Cmd for Ctrl on the Mac). And then we have the "in menu"
shortcuts - and those are truly ill maintained.

In Linux, when you hold down the Alt key, you'll see that certain letters
in the menu are underlined, using those letters you can now run Subsurface
with just the keyboard. So, Alt-F opens the File menu, a subsequent Alt-R
opens the P_references.

A long time ago I tried to get these to be unique and make some sense, but
I never stayed consistent and certainly never even tried to look into
these in the translations. I honestly doubt that anyone uses them.

> > These shortcuts are one thing that I continuously keep forgetting to look
> > into: I have the impression that at least on Mac, the shortcuts disappear
> > when running Subsurface in German. Unfortunately, changing language settings
> > on Mac needs a reboot. So I cannot simply check… Has anybody else
> > encountered this? And what could be the reason?
> The menu shortcut is indicated with an ampersand in the source code
> and might well be missing from translations. However, in German it
> they seem to be mostly present when running on LInux (following works
> on Linux to switch language: LANGUAGE=de_DE subsurface)

Again, on all our OSs you can switch language in the preferences and
re-start Subsurface.


More information about the subsurface mailing list