Help installing Subsurface in Ubuntu?

Frank O'Donnell ssf at inkbox.net
Mon Jun 5 20:28:08 PDT 2017


Rick, thanks for the very helpful message.

On 6/5/17 7:57 PM, Rick Walsh wrote:
> Install prerequisites for Subsurface and the additional prerequisites 
> for the SmartTrak tool.
> |sudo apt-get install git g++ make autoconf libtool cmake pkg-config 
> libxml2-dev libxslt1-dev libzip-dev libsqlite3-dev automake 
> libusb-1.0-0-dev libgit2-dev libssl-dev qt5-default qt5-qmake 
> qtchooser qttools5-dev-tools libqt5svg5-dev libqt5webkit5-dev 
> libqt5qml5 libqt5quick5 libqt5declarative5 qtscript5-dev libssh2-1-dev 
> qttools5-dev qtpositioning5-dev qtconnectivity5-dev libglib2.0-dev 
> mdbtools-dev|
> Get the sources for the latest stable version of Subsurface:
> |mkdir -p ~/src cd ~/src git clone 
> git://github.com/Subsurface-divelog/subsurface 
> <http://github.com/Subsurface-divelog/subsurface> cd subsurface git 
> checkout v4.6.4|
|The above steps appeared to go smoothly|
> Configure to build the SmartTrak tool
> ccmake build
> Scroll down to SMARTTRAK_IMPORT and hit enter to change to ON, then 
> "c" to configure, and "g" to save and exit
Here I ran into a problem. When I executed "ccmake build," it complained 
that no /build directory existed. I therefore tried adding a directory 
~/src/subsurface/build. When I ran "ccmake build" again, it now 
complained that there was no CMakeLists.txt file in the /build directory.

I noticed that there are a total of 12 files named CMakeLists.txt in the 
~/src/subsurface directory tree. I tried copying the one in 
~/src/subsurface to ~/src/subsurface/build. Now when I ran "ccmake 
build," it displayed the message EMPTY CACHE and I wasn't able to scroll 
down to make the described change.

Any thoughts on how to resolve this? I appreciate your offer of 
converting my .slg file, but I'd really like to get smtk2ssrf working if 
at all possible.

Thanks again,

Frank

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20170605/9614a9dc/attachment.html>


More information about the subsurface mailing list