Overthinking on Subsurface mobile app UX

James Cialdea jamescialdea at gmail.com
Thu Jun 22 06:12:07 PDT 2017

I'm able to get the screen stuck with white space at the top 100% of the
time using this procedure:

1. Scroll to the top of the dive list
2. Drag down (scrolling up past the top of the list)
3. Do not release, hold the screen in position while the update happens
4. Allow the update to complete while holding the screen scrolled past the

This gets me half an empty screen every time.

Interestingly, repeating the procedure doesn't make more empty space. Even
more interesting, performing an update while the extra empty space is
there, but where you don't hold the screen past the top during update
removes the empty space.

Pixel XL, Android 7.1.2, using the build from Dirk around 9hr ago.

On Jun 22, 2017 5:30 AM, "Rick Walsh" <rickmwalsh at gmail.com> wrote:

On 22 June 2017 at 19:57, Rick Walsh <rickmwalsh at gmail.com> wrote:

> b) pull down the dive list to refresh / sync with the cloud server
> That is a great improvement. I actually stayed up last night and tried to
> work out how it could be done. But it doesn't quite work for me. The list
> doesn't bounce back up on release. Then if you try again, it gets dragged
> down further. See my screenshot (with
> I tried to reproduce this with the hope of debugging it, but now it works
as expected.  I did come across a perhaps related bug where the spinner
persisted after a failed attempt to refresh.  2-line patch sent the
old-fashioned way.

subsurface mailing list
subsurface at subsurface-divelog.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.subsurface-divelog.org/pipermail/subsurface/attachments/20170622/38e142c5/attachment.html>

More information about the subsurface mailing list