direct import form dive computer

Alessandro Volpi volpial at
Sun Mar 12 10:52:21 PDT 2017

Dear Jef,

I apologize for not having actually loaded the
subdirectory galileo_trimix_import on my Dropbox folder. The Galileo data
download was executed on a laptop computer. The Ubuntu trusty system is not
set up so that it automatically starts the Dropbox sync operation, as usual
for laptops, which may not be always connected to Internet. I just forgot
to manually start the Dropbox sync, after having created the mentioned
directory. If you open my Dropbox folder right now you are going to find it
as expected.

In the same folder you will also find the subdirectory Smarttec_import ,
with the log file.

I have not hitherto considered the chance of installing the Windows version
of subsurface on the WXP VM .  I thought it might have been be a good
suggestion, just in order to try to get the memory dump. It is  a bit
funny, since I have begun to look for linux dive log software mainly in
order to get rid of the WXP virtual machine ...

I have also tried this possible solution. Subsurface seems to be flawlessly
installed, but it does not work. As I try to launch it I only get an error
pop-up saying : "The procedure entry-point qsort_s could not be located in
the dynamic link library msvcrt.dll" .  This is not surprising since, in
the subsurface web site, WXP is not mentioned in the list of the subsurface
supported Microsoft operating systems.

As far as the reasons for not being able to connect the SmartTec to the
linux ( Ubuntu trusty ) IR interface, I think it may be related to the fact
that, even with the SmartTrak program running on the WXP VM, the SmartTec
takes much more time than the Galileo for the download, in spite of the
fact that the amount of data sent by the former is much smaller than that
sent by the latter. This means that the transmission data rate of the
SmartTec is much lower.

Best regards.


On Sun, Mar 12, 2017 at 9:39 AM, Jef Driesen <jef at>

> On 11-03-17 23:41, Alessandro Volpi wrote:
>> I have downloaded the full memory content of my Galileo Trimix computer.
>> The resulting files can be found in my Dropbox folder, subdirectory
>> galileo_trimix_import :
>> 3HngCNq3a?dl=0
> I don't see a galileo_trimix_import there.
> I have also tried to do the same with my SmartTec computer.
>> For my dives I usually wear both computers, so that their contents should
>> be the
>> same.
>> Unfortunately I was not able to download any file from the SmartTec.
>> The subsurface error message is "Could not connect to the SmartTec
>> computer" or
>> something similar.
> Can you send me the logfile of the download? That might give me some more
> info on what exactly is going wrong. Without the logfile, the only thing I
> can do is guess.
> The SmartTec computer hardware is working perfectly. I have downloaded 112
>> dives
>> form its memory relying on SmartTrak; the program was executed on a
>> virtual
>> Windows XP system on the same computer used for downloading the Galileo
>> Trimix
>> files.
> Have you tried downloading with subsurface on the same Windows XP VM? If
> it works there, then the problem is most likely linux IrDA related.
> I guess that some bug in the IR interface causes the failure of the data
>> download  from the SmartTec.
>> It is worth while to mention that the IR interface is a package not being
>> maintained for many years.
>> The interface works with Ubuntu Trusty, at least with the Galileo Sol
>> device.
>> It DOES NOT WORK AT ALL with newer systems, such as Ubuntu xenial and
>> Fedora 24.
>> I would like to try once again, if you or someone else in the mailing
>> list can
>> give me some suggestions about connecting the SmartTec with the linux IR
>> interface.
> Did you already try to download the SmartTec on the Ubuntu Trusty, where
> the Galileo is working fine?
> Jef
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list