Initial crash in MacOS Sierra

Thiago Macieira thiago at macieira.org
Fri May 26 12:53:54 PDT 2017


On segunda-feira, 15 de maio de 2017 01:55:33 PDT Robert Helling wrote:
> Thiago,
> 
> could you please have a look at this:
> https://github.com/Subsurface-divelog/subsurface/issues/398#issuecomment-30
> 1407498
> 
> User reports Subsurface crashing on start up and it seems it is in the
> intial network operation where it determines if it is the latest version.
> Somehow it seems Qt-networking is calling into CoreFoundations with an
> illegal nil argument.
> 
> Needless to say, I cannot reproduce this problem here.

Hi Robert

I haven't yet got Subsurface to build on my Mac, so I couldn't debug yet. I'm 
trying to fight CMake so that it will find OpenSSL properly: my Mac is a little 
unusual in that I didn't install the Xcode Command Line tools, but instead I 
added 

  /Applications/Xcode.app/Contents/Developer/Toolchains/
XcodeDefault.xctoolchain/usr/bin

to $PATH instead. So I keep getting now:

 ld: library not found for -lssl

The older SDKs (for macOS 10.8 through 10.10) had libssl.dylib, but the newest 
Xcode only carries the 10.12 SDK and that doesn't have libssl.dylib.

-- 
Thiago Macieira - thiago (AT) macieira.info - thiago (AT) kde.org
   Software Architect - Intel Open Source Technology Center



More information about the subsurface mailing list