Bluetooth fails on mobile

Davide DB dbdavide at
Fri Apr 13 00:05:21 PDT 2018

On 12 April 2018 at 17:07, Davide DB <dbdavide at> wrote:
> On 12 April 2018 at 17:01, Dirk Hohndel <dirk at> wrote:
>> Oops. On the first version Nexus 7? That should be impossible.
>> I own several first version Nexus 7 and they didn't support BLE, I'm
>> quite certain about that.
>> You will see that the 2012 version only support BT 3.0, it's the 2013
>> version that adds BT 4.0 (and therefore BLE).
> I will try again this evening (CET) at home.
> IIRC On the Nexus 5x once paired on the bluetooth info I see LE:address
> On the Nexus 7 once paired I see only the address (the same as the
> other phone) so I selected that address form Subsurface download drop
> down.
> This evening I will try to install a screen recorder on that ancient
> tablet so i will post a video.
>> I start the download
>> Subsurface start counting downloaded dives...
>> On Petrel I see SENDING PACKET messages
>> At some point on my Petrel I get ERROR SENDING PACKET and the Petrel UI
>> quits.
>> OK so far.
>> On Subsurface mobile the UI is stuck on something like downloading
>> dive #[dive number]
>> The UI loops indefinitely with this message. Whatever I do when I go
>> back on the download from dive computer screen its' always in the
>> download state. Buttons don't work.
>> It should time out.
>> Can you try this? After you've seen about 5 dives downloaded (why is it
>> re-downloading dives you already have? you said only 3 were missing)
>> please tap the Cancel button on the UI. That should cancel the BT download
>> and show you the partial download which you can then save.
>> Looking to the app logs via developer's options I see something like
>> this: (English translation between parenthesis are mine)
>> "143.271: dive #18 dom 24 set 2017 11:29"
>> "LocalDeviceBroadcastReceiver::onReceive() - event:
>> andorid.bluetooth.device.action.ACL_DISCONNECTED"
>> QMutex: destroying locked mutex
>> Executing queued closeSocket()
>> AppState changed to inactive with no save ongoing and unsaved changes
>> "Save changes to local cache"
>> Sincronizzazione dei dati in corso (ongoing data sinc)
>> preparazione al salvataggio dei dati (preparing to save data)
>> Inizio salvataggio dei dati (starting saving data)
>> Inizio salvataggio delle immersioni (starting saving dives)
>> AppState changed to active with save ongoing and unsaved changes
>> AppState changed to suspended with save ongoing and unsaved changes
>> Creazione della cache locale riuscita
>> QEGLPlatformContext: eglSwapBuffers failed: 300d
>> done saving to git local / remote
>> I'm not a  developer but from logs I see that 18 dives where
>> downloaded (I need only the newest three of them)
>> it's like the downloading thread has successfully stopped and some of
>> the dives are being saved
>> somewhere... But even restarting Subsurface nothing has changed into
>> my dive list.
>> I attached a screenshot of the whole log.
>> I know that I could get the log file connecting via USB but given that
>> we already have a text canvas (or something like that) wich shows me
>> the log why don't you enable the copy paste or use another kind of
>> widget so a user can easily forward it directly from Subsurface UI?
>> That's a QML problem (the UI toolkit that we use). I need to ping
>> the QML developers to find out when that will be possible.
>> But if you have an email app on the Nexus 7, you should be able
>> to simply attach the subsurface.log from the root of your storage
>> device to an email...
>> /D
> I could not find that file. i have to install some file manager app.
> Anyway I will test everything this evening.

I tried again yesterday.

When on my Petrel I get ERROR SENDING PACKET the Subsurface mobile UI
remains waiting in download mode endlessly no matter which button I

I tried again and, as Dirk suggested, after few dives were downloaded
I tried canceling the download from Subsurface mobile UI and it works.
It shows me the successfully downloaded dives and I can save them.

I made another test:

- During the download I cancel it.
- Petrel immediately exit the download mode.
- Subsurface shows me successfully downloaded dives.
- Now I have the option to accept /refuse them but I have the option
to resume/try again the download too.
- I try again to download but the Petrel is not in download mode anymore.
- Subsurface tells me that cannot find the Petrel.
- I quit the download procedure.
- Subsurface crash.

I inspected the log file but I found no trace of the crash or error. I
forgot to save the file, sorry. I was very tired and I will try again

I'll write a separate email on a small quirkiness I found on the
mobile UI strings.



More information about the subsurface mailing list