Any brave dive computer download testers out there?

Matt Thompson mathomp at
Thu Apr 19 19:56:12 PDT 2018

On Wed, Apr 18, 2018 at 4:01 PM, Dirk Hohndel <dirk at> wrote:

> We now have binaries for Windows, Mac, and Linux (AppImage only) available
> in order for people to test this.
> tag/continuous-NG
> I tested all three of my computers on Windows 10, macOS 10.13.4, and
Fedora 27.

My Aqualung i750TC worked correctly on all three platforms using the USB

My Atomic Cobalt2 worked on Windows and macOS but failed on Linux.  I think
the failure on Linux is a configuration issue on my part but for
completeness I get the following in the console:
ERROR: Failed to open the usb device. [in ../../src/atomics_cobalt.c:117
INFO: dc_deveice_open error value of -6
I get that error on both Subsurface-4.7.8-73-ga12ea13d51f5-x86_64.AppImage
and Subsurface-4.7.8-x86_64.AppImage.

My Suunto D4i failed on all three platforms.  It gave various errors on the
Windows 10:
 the red banner at the bottom of the main window with the message
"Unsupported operation"

Fedora: A message box  with the message "Unable to open /dev/ttyUSB0" and a
message on the console "ERROR: Failed to receive the answer. [in
../../src/suunto_d9.c:253 (suunto_d9_device_packet)]

macOS: A message box with the message "Error downloading dive data"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list