Any brave dive computer download testers out there?

Willem Ferguson willemferguson at
Tue Apr 24 11:25:43 PDT 2018

On 24/04/2018 20:08, Linus Torvalds wrote:
> On Tue, Apr 24, 2018 at 11:03 AM, Willem Ferguson
> <willemferguson at> wrote:
>> Initial handshaking took maybe 40s, showing error message in red bar at
>> bottom of screen "Timeout"
> Hmm. It looks like it first tried to do a BLE download, and that
> failed (and this is what took a longish time).
> And then because of the failure, it fell back on old-style BT rfcomm, and:
>> But, if not interrupted, the download proceeded perfectly shortly after the
>> timeout message and download exited normally on the GUI.
> .. apparently rfcomm works for you and the fallback was successful.
> Has BLE ever worked for you?


I did the same download by setting the dropdown option in the BT setup 
panel to 'Force Classical'. Took about 25 sec to do handshaking, still 
getting "Timeout while trying to connect". Does not appear to make 
difference and successful end result is same as previously, downloading 
all my dives. Interesting error message at end of log. I have never 
managed to get the BLE working. My Petrel is pretty recent, so I am 
reasonably sure it can do both. But the user manual and the Shearwater 
website does not provide any insight into this.

Desktop$ ./Subsurface-4.7.8-73-ga12ea13d51f5-x86_64.AppImage
can't find Subsurface localization for locale "en-ZA"
Missing CAP_NET_ADMIN permission. Cannot determine whether a found 
address is of random or public type.
Starting download from  BT
Starting the thread 0
Enabling GATT request timeout behavior 20000
qt_ble_open( 00:13:43:5B:8F:BE )
Creating default GAP/GATT services
addresstypeToUse: "Random"
No settings found for peer device.
HCI event triggered, type: e
HCI event triggered, type: e
timeout while trying to connect to the controller 00:13:43:5B:8F:BE
void QBluetoothSocketPrivate::_q_readNotify() 28 error: -1 "Resource 
temporarily unavailable"
Connection on channel 1 failed. Trying on channel number 5.
INFO: dc_device_open error value of 0
[39.400513] ERROR: Failed to download the dive. [in 
../../src/shearwater_petrel.c:330 (shearwater_petrel_device_foreach)]
Finishing the thread Dive data import error dives downloaded 9

Kind regards,


This message and attachments are subject to a disclaimer.

Please refer to 
<> for

More information about the subsurface mailing list