Troubles with SmartTrak log import

TACHOUERES Franck franck.tachoueres at
Tue Aug 14 11:44:29 PDT 2018

Hi everyone,

I just achieved my diving log import completion.
Smtk2ssrf worked fine for all my dives except the #412 (found by dichotomy).

So now I have a complete ssrf log with many dive curves and i am glad with

A big thank you for all your work ;-)


2018-08-14 19:52 GMT+02:00 Linus Torvalds <torvalds at>:

> On Sat, Aug 11, 2018 at 2:35 AM Salvador Cuñat <salvador.cunat at>
> wrote:
> >
> > The issue is quite weird:
> > 1.- I can only reproduce it with Franck's file.
> > 2.- It crashes with previous versions (at least not a regression).
> > 3.- We get a SIGBUS while running release mode, but not in debug mode.
> Have you tried running it under valgrind?
> valgrind is quite good at finding "oops, the program does something
> wrong" that causes random memory corruption etc.
> How do you even build that SmartTrak importer? Not that I'll likely
> have any time to look at it since I'm in the kernel merge window hell
> right now.
>                Linus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list