MXE with Qt5.11.1 and missing map

Stefan Fuchs sfuchs at
Mon Jul 9 22:32:54 PDT 2018

Hallo Dirk,

Refreshing your memory regarding QtPositioning plus finally answering your question below...

> Am 25.06.2018 um 21:46 schrieb Dirk Hohndel <dirk at>:
>>> On Jun 26, 2018, at 2:38 AM, Stefan Fuchs <sfuchs at> wrote
>> I tried to do this a few days ago but I now see a issue with map not displayed. Instead I do see the "QML module QtLocation and QtPositioning" error. But as far as I can see DLLs are there in version 5.11.1
> I saw similar feedback from people building with 5.11 on some Linux flavors. I upgraded my Arch Linux yesterday and the map worked there - but as I said, I haven't played with this for MXE. My guess would be that it's not the DLLs but the qml modules that are missing.
>> In the shell I have this error:
>> qrc:/qml/MapWidget.qml:4:1: plugin cannot be loaded for module "QtPositioning": Die Bibliothek C:\Program Files (x86)\Subsurface\qml\QtPositioning\declarative_positioning.dll kann nicht geladen werden: Das angegebene Modul wurde nicht gefunden.
>> QUrl("qrc:/qml/MapWidget.qml") failed to load with status: QQuickWidget::Status(Error)
> I take it back, it clearly is looking for a DLL. And when you look at the installed version, the library is right where Subsurface is looking for it? Or is it missing from the installer?
The new 5.11.1 library file was there in the right position. No clue why Qt complained.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list