Bluetooth nonfunctional

Dirk Hohndel dirk at
Sun May 13 12:55:21 PDT 2018

> On May 13, 2018, at 12:36 PM, Linus Torvalds <torvalds at> wrote:
> On Sun, May 13, 2018 at 12:00 PM Willem Ferguson <
> willemferguson at> wrote:
>> Thank yo so much for your time, Linus. Nope, same error. Error bar at
>> bottom of Subsurface screen "Unsupported operation".
> Yeah, that's just the "none of the protocols we tried worked" error case.
> The real problem is simply this:
>> Failed to connect to device  00:13:43:5B:8F:BE .
>> Device state QBluetoothSocket::UnconnectedState .
>> Error: QBluetoothSocket::UnknownSocketError
> So it's simply that Qt doesn't successfully connect to the device at all,
> and we never even get to the point where we can talk to it.
> Why _that_ happens, I have absolutely no idea. There is simply not a lot of
> information to go on. It's like the device isn't paired.

In my experience with the Petrel 2, once it decides to be stupid, it stays
stupid. Remove the battery for at least 15 minutes. Forget the pairing on
your computer. Insert battery, fix clock, pair again with your computer.
Try again.

At one point I had to do that three times until it decided to play with my
Mac again. There is something SERIOUSLY broken - and my current
guess is that it's in the BT/BLE stack on the Shearwater Petrel 2


More information about the subsurface mailing list