Missing pO2 samples from CCR download [was: 4.7.8: a couple of questions]

Davide DB dbdavide at gmail.com
Wed May 23 02:01:21 PDT 2018


Hi guys,

Is there any chance that one day it will be possible to see O2 sample on a
CCR dive?
On Thu, 10 May 2018 at 22:48, Davide DB <dbdavide at gmail.com> wrote:

> On Thu, 3 May 2018 at 21:39, Davide DB <dbdavide at gmail.com> wrote:

> > On Thu, 3 May 2018 at 18:52, Anton Lundin <glance at acc.umu.se> wrote:

> >> On 03 May, 2018 - Davide DB wrote:

> >> > On Thu, 3 May 2018 at 13:15, Anton Lundin <glance at acc.umu.se> wrote:
> >> >
> >> > > On 03 May, 2018 - Davide DB wrote:
> >> > >
> >> > > > On Wed, 2 May 2018 at 11:04, Anton Lundin <glance at acc.umu.se>
> wrote:
> >> > > >
> >> > > > >
> >> > > > > Try to download them into a fresh logbook with the current
> desktop
> >> > > > > version, to see what's happens then.
> >> > > > >
> >> > > >
> >> > > > I've just downloaded my dives on a fresh Win10 4.7.8
installation.
> >> > > > As usual after few dives my Petrel quits with "error sending
packet
> >> > > error".
> >> > > > I saved some of them anyway and PO2 values are missing.
> >> > > > This is how the petrel controller is recognized. File is
attached.
> >> > > >
> >> > > > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'
> >> > > > diveid='2e7067fb' dctype='CCR'>
> >> > > >
> >> > > > There's no mention of O2 sensor.
> >> > > >
> >> > > > These are all different pertel descriptions of the very same dive
> >> > > computer
> >> > > > I found in my original logbook
> >> > > >
> >> > > > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'
> >> > > > diveid='3db7eb77' dctype='CCR' no_o2sensors='1'>
> >> > > > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'
> >> > > > diveid='52d4ba3e' dctype='CCR' no_o2sensors='3'>
> >> > > > <divecomputer model='Shearwater Petrel' deviceid='1a2d46b1'
> >> > > > diveid='a6e05a10' dctype='CCR'>
> >> > > > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'
> >> > > > diveid='3db24900' dctype='CCR'>
> >> > > >
> >> > > > Were pO2 samples download removed?
> >> > >
> >> > > This is probably because we can't find any calibration values in
your
> >> > > computer. Did you get a warning:
> >> > > "Disabled all O2 sensors due to a default calibration value." ?
> >> > >
> >> > > I think the code should fall back to the sensor average po2 when we
> >> > > won't get calibration values for the sensors, but we're not doing
> that
> >> > > right now.
> >> > >
> >> >
> >> > Anton,
> >> >
> >> > I'm not crazy enough to dive a rebreather without a proper
calibration.
> >> > Everything is ok on my unit. Cells are new and get calibrated before
> every
> >> > dive.

> >> Shure. The computer is probably properly calibrated, but the
> >> calibration values found in the memory of the computer are the default
> >> ones. Without those we can't convert the mV values to po2 values.

> >> The cal values might be there somewhere, but we don't know where.

> >> We can't emit the raw mV values, because neither libdivecomputer nor
> >> subsurface supports mV values.

> >> > I tried to download again from Shearwater desktop and everything is
> there:
> >> > pO2 and mV samples. I've never updated my Petrel since we found that
> >> > Subsurface pO2 values were completely wrong so I guess it should be
> some
> >> > bug arose lately.
> >> > It's sad nobody else (ccr users) replied to my feedback request when
I
> >> > noted the pO2 discrepancy. I cannot believe I'm the only one on this
> list
> >> > using a ccr unit whit a divecan shearwater controller.
> >> >  When I realized pO2 were missing I thought it was something related
> to the
> >> > mobile download but it's not.
> >> >
> >> > I would do a full Subsurface download but I drained another battery
> but I
> >> > do not have a new one around ATM.

> >> We should at least emit the per sample average, when we can't emit the
> >> individual sensor values.

> >> Best would be if we could emit both the "true" average po2 and the
> >> individual sensor values. Unfortunately the interface doesn't support
> >> that distinction.


> > I changed battery and downloaded again with subsurface 4.7.8 desktop
> saving the libdivecomputer log file.
> > I quit the download before getting errors and draining my battery.
> > At the end of the libdivecomputer file I find:

> > WARNING: Disabled all O2 sensors due to a default calibration value. [in

/home/travis/build/Subsurface-divelog/subsurface/libdivecomputer/src/shearwater_predator_parser.c:503
> (shearwater_predator_parser_cache)]
> > INFO: Write: size=9, data=FF0105002E902000C0

> > Exactly the problem mentioned by Anton.

> > Could someone explain me what does it means?
> > Is it a way to avoid displaying wrong pO2 samples due to the previous
> problem?
> > What can I do? Is it my fault? Is my Petrel defective?

> > Why in my logbook I find 4 different computer names with different
> attributes if my unit is always the same?

> > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'>
> diveid='3db7eb77' dctype='CCR' no_o2sensors='1'>
> > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'>
> diveid='52d4ba3e' dctype='CCR' no_o2sensors='3'>
> > <divecomputer model='Shearwater Petrel' deviceid='1a2d46b1'>
> diveid='a6e05a10' dctype='CCR'>
> > <divecomputer model='Shearwater Petrel 2' deviceid='1a2d46b1'>
> diveid='3db24900' dctype='CCR'>

> > Are those differences due to subsurface history reason?

> > Thank you in advance

> > --
> > Davide
> > https://vimeo.com/bocio/videos



> Thank you guys

> --
> Davide



-- 
Davide
https://vimeo.com/bocio/videos


More information about the subsurface mailing list