dive merge seems broken in latest master

Jan Mulder jlmulder at xs4all.nl
Mon Oct 15 02:42:26 PDT 2018

On 10/15/18 9:10 AM, Jan Mulder wrote:
> On 10/15/18 9:06 AM, Berthold Stoeger wrote:
>> On Monday, 15 October 2018 08:53:16 CEST Jan Mulder wrote:
>>> Tried to reproduce things. As I do not have 2 DCs, I fake a second one
>>> just by editing the ssrf XML. I cannot reproduce it (in this way).
>> I can trivially reproduce this by importing a divelog onto itself. 
>> Therefore,
>> this should be easy to fix. I'm heading of to lecture now and will 
>> look at
>> this in the later afternoon.
> Yes, this produces a crash indeed. Not 100% sure this the same one.

Tried to make sense of this. The first attempt crashed immediately, but 
subsequent sessions did not. In the debugger, I saw that the trips dives 
list (double linked list it seems) is corrupted. Then I had a couple of 
runs the ended in an endless loop in the import on itself phase, and 
finally, all works ...

So, to me, it seems non-deterministic caused by memory corruption 
somewhere. Curious what the root cause here, but it does not feel "easy 
to fix" to me.


More information about the subsurface mailing list