subsurface builds, but dumps core at startup :(

Salvador Cuñat salvador.cunat at
Tue Sep 11 12:30:46 PDT 2018

Good night Cristian

On Tue, Sep 11, 2018 at 08:23:13AM -1000, Linus Torvalds wrote:
> On Tue, Sep 11, 2018 at 8:15 AM Cristian Ionescu-Idbohrn
> <cristian.ionescu-idbohrn at> wrote:
> >
> > > I had a similar unexplained SIGSEGV that went away when building the
> > > whole tree from scratch.
> >
> > I did so too (I think).  Still no joy :(
> Note that for me, it was subsurface itself that had the issue, not
> just the googlemaps plugin.
> But it was literally a "I can't make sense of that SIGSEGV", so I just
> nuked absolutely everything, so I'm not entirely sure what went wrong.

I've been having same issue (in debian/unstable) for a while now, and, as Linus
points out subsurface's build dir needs to be removed. I also remove the
googlemaps dir and then run

In my case, the binary in subsurface/build still SIGSEVs but the one
installed in install-root/bin (or system wide /usr/local/bin) runs
without map, throwing an error:

MapWidget.qml: cannot find a plugin named: googlemaps
qrc:/qml/MapWidget.qml:24: Error: Cannot assign [undefined] to QDeclarativeGeoMapType*

but at least runs.

I've also tried 4.8.1 AppImage, but it's also failing:

Auto configuration failed
140221893212608:error:25066067:DSO support routines:DLFCN_LOAD:could not load the shared library:dso_dlfcn.c:185:filename( no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
140221893212608:error:25070067:DSO support routines:DSO_load:could not load the shared library:dso_lib.c:244:
140221893212608:error:0E07506E:configuration file routines:MODULE_LOAD_DSO:error loading dso:conf_mod.c:285:module=ssl_conf, path=ssl_conf
140221893212608:error:0E076071:configuration file routines:MODULE_RUN:unknown module name:conf_mod.c:222:module=ssl_conf
QMutex: destroying locked mutex
Violación de segmento

Best regards.


More information about the subsurface mailing list