Subsurface mobile 2.1.3( Pelagic data cable issues

Bill Perry bperrybap at
Wed Sep 19 11:49:45 PDT 2018

Ok, it seems that there is a newer version of Subsurface mobile available now. 2.1.3(
vs the 2.1.2( that was released yesterday.

While this release is better, it still has issues.

Downloads are now working on the GS7 (Android 8.0.0)
But it still doesn't work on the GS4 (Android 4.4.4)
(The subsurface 4.8.1 that I built from sources worked on both the GS7 and the GS4)

The app on the GS4 was upgraded from 2.1.2( to 2.1.3(
When the data cable was plugged in Subsurface was not showing up as an app to use the usb device. (It does on the GS7 running Android 8.0.0)
The app was started manually, and it jumped to the divelist sreen with all the cloud synchronized dives.
I went to try a download using the FTDI data cable for the Aeris Atmos AI.
When [Download] was clicked the app crashed just like with 2.1.2(

I then uninstalled the app, and re-installed it.
I started the app. It asked for cloud credentials which I entered and it synchronized.
I exited the app, and plugged in the data cable. The subsurface app does not show up as an app to use the USB device.
(It does on the GS7 running Android 8.0.0 and and it did when running a 4.8.1 mobile app that I built from sources)
When [Download] is clicked the download fails.
I'm assuming that this is related to the app not showing up and being selected for using the USB device when the datacable is plugged in.

Here is the output from libdivecomputer.log

Subsurface: v4.8.2-5-g4fc0d9ee132c, built with libdivecomputer v0.7.0-devel-Subsurface-NG (fb70928c83ee09f7a74158d7c316fb18334caf6e)

Here is the relevant part of subsurface.log

"60.711: DCDownloadThread started for Aeris Atmos AI on FTDI"
Starting download fromĀ  ftdi
"60.781: Looking at device with VID/PID 1478/36940"
"60.781: Looking at device with VID/PID 1027/62560"
"60.782: usbManager tells us we don't have permission to access this device"
"60.782: Input/output error"
Finishing download thread: "Unable to open ftdi Aeris (Atmos AI)"
no new dives downloaded
"60.840: DCDownloadThread finished"
"66.989: AppState changed to inactive with no save ongoing and no unsaved changes"
"67.557: AppState changed to suspended with no save ongoing and no unsaved changes"

There is also one new minor annoyance.
The code is now trying to be "smart" by jumping directly to the dive download screen
and pre-selecting a the vendor name when the datacable is plugged in.

This seems nice, but in my case, the vendor of the cable is Oceanic but the dive computer is Aeris.
And even if I did have an Oceanic dive computer, it doesn't remember the last used dive computer.
It seems like simply remembering the last used device information (vendor name, dive computer, connection)
would actually be MUCH simpler and right more often than trying to guess the correct one,
particularly when the user is repeatedly doing downloads from the same dive computer say daily during a dive tripĀ  - which is my usage case.

Perhaps there could be some smarts that if the VID/PID match the last used on, that all the last used settings are used.
If VID/PID doesn't match the last one used, then try to guess or just don't fill in anything just to keep things really simple.

--- bill

More information about the subsurface mailing list