[TEST REQUEST] Windows Bluetooth LE build

Linus Torvalds torvalds at linux-foundation.org
Sat Sep 29 14:54:24 PDT 2018

On Sat, Sep 29, 2018 at 2:25 PM Steve <stevewilliams at internode.on.net> wrote:
> Ok another test but this time even though I paired with Windows settings properly twice and it said it was setup it looked to me as if it was not paired correctly so I tried with Bluetooth LE Explorer and paired with that (as I did for the OSTC3+) and this time it looks better but still not working.

This actually looks fine:

> Found service "{00001800-0000-1000-8000-00805f9b34fb}" "Generic Access"
>    c: "{00002a00-0000-1000-8000-00805f9b34fb}"
>    c: "{00002a01-0000-1000-8000-00805f9b34fb}"
> Found service "{0000180a-0000-1000-8000-00805f9b34fb}" "Device Information"
>    c: "{00002a29-0000-1000-8000-00805f9b34fb}"
> Found service "{fe25c237-0ece-443c-b0aa-e02033e7029d}" "Unknown Service"
>    c: "{27b7570b-359e-45a3-91bb-cf7e70049bd2}"
>         d: "{00002901-0000-1000-8000-00805f9b34fb}"
>         d: "{00002902-0000-1000-8000-00805f9b34fb}"

It has discovered the LE GATT services..

>  .. ignoring standard service "{00001800-0000-1000-8000-00805f9b34fb}"
>  .. ignoring standard service "{0000180a-0000-1000-8000-00805f9b34fb}"
> Using service "{fe25c237-0ece-443c-b0aa-e02033e7029d}" as preferred service

and it picked the usual non-standard one, which is correct for Petrel.

>  .. enabling notifications
> Using read characteristic "{27b7570b-359e-45a3-91bb-cf7e70049bd2}"
> now writing "0x0100" to the descriptor "{00002902-0000-1000-8000-00805f9b34fb}"

And it has enabled notifications on the right descriptor.

> INFO: dc_device_open error value of 0
> QTime("06:47:20.208") packet SEND "0100ff0105002e902000c0"

Now it sends the 2e:90:20:00 command (the rest is header and the END byte)

But the above is the "device close" command. It never sent anything else.

In other words: the above looks 100% correct, with no errors anywhere,
but there's not even an attempt at IO.

Your libdivecomputer log-file backs that up. All it does is open it
successfully, and send the end command. Very odd.



More information about the subsurface mailing list